Overview of Sheet Set Manager Objects [Sheet Set Objects Reference: SSO]

Overview of Sheet Set Manager Objects

The Sheet Set Manager API is based on a set of COM objects. You can use the COM objects of the Sheet Set Manager to develop macros and applications that create sheet sets and perform related tasks.

AcSmSheetSetMgr allows you to open and create sheet set databases (AcSmDatabase) as well as determine which databases are already open.

AcSmDatabase contains a hierachy of objects that includes subsets and sheet objects. The sheet set database also contains various properties including version information and the main sheet set object. You can call the GetSheetSet method to retrieve a pointer to the main sheet set object (AcSmSheetSet).

AcSmSheetSet contains a collection of subsets and sheets (AcSmSubset and AcSmSheet, respectively). AcSmSubset is a collection that can contain sheets and/or other subsets. AcSmSheet is an object that references a specific layout within a specific drawing file. A sheet object contains information about the associated drawing file name, layout name, and handle, as well as other information such as sheet number, description, and so on.

You can view the Sheet Set Manager objects in the AutoCAD VBA integrated development environment (VBA IDE) and in Microsoft Visual Studio 2005 (Version 8). To view the objects using the Object Browser in the VBA IDE, add a reference to the AcSmComponents17 1.0 type library. The file, AcSmComponents17.tlb, is in the following folder: C:\Program Files\Common Files\Autodesk Shared.

A sample project that shows how to use the Sheet Set Manager objects is in the following folder: C:\Program Files\AutoCAD 2007\Sample\ActiveX\SheetSetVBA.


Sheet Set Object Model [Sheet Set Objects Reference: SSO]

Sheet Set Object Model

Click an object or collection to view the description.


Guidelines for Modifying a Sheet Set [Sheet Set Objects Reference: SSO]

Guidelines for Modifying a Sheet Set

The sheet set API is a multiclient API. This means that multiple clients may be viewing and interacting with a given AcSmDatabase at any given time. This requires special attention as to how objects are referenced or modified in the database.

In order to make modifications to any object within the AcSmDatabase, you must lock it and then unlock it when you are finished making changes. You should only lock the database when you are ready to make changes, and you should unlock it as soon as possible. For performance reasons, you should also lock and unlock the database as few times as possible. If you need to make several modifications, lock the database, make all your changes, and then unlock it.

Because the database has multiple clients, it will be automatically reloaded from time to time as other clients make changes. When the database gets reloaded, all contained object instances are discarded and new instances are created as the database is read in.

For this reason, it is important to adhere to the following basic rule when referencing objects that reside within a sheet set database:

  • Never cache direct pointers to objects within a sheet set database. If you must cache a reference to an object within a sheet set database, store the associated IAcSmObjectId instead. With an object ID, you can safely retrieve a pointer to the associated object instance; the current instance is always retrieved.

After a database is reloaded, a pointer to a database-resident object will be invalid. However, if you store the object ID instead, you can use it to safely retrieve a pointer to the current object instance.

The only exception to this rule is the database. You can store a pointer to the AcSmDatabase because the database object is not destroyed and recreated during a reload operation.

You can retrieve the object ID of any database-resident object by calling the GetObjectId method on the object. Conversely, you can get the associated object instance from an ID by calling the GetPeristentObject method. This returns a general IAcSmPersist interface pointer, which can be queried for the desired interface.

Note: DST files should only be modified using Sheet Set Manager objects.


Create or Open a Sheet Set Database [Sheet Set Objects Reference: SSO]

Create or Open a Sheet Set Database

To use Sheet Set Manager objects, you must use an AcSmSheetSetMgr object and one or more AcSmDatabase objects (DST files).

After you create an AcSmSheetSetMgr object, you can use the CreateDatabase method to create an AcSmDatabase object. Specify a file name with a DST extension. Alternatively, you can use the OpenDatabase method to open an existing database. You can also access databases that are currently open. Use the GetDatabaseEnumerator method to obtain an enumerator that provides access to the list of open databases. You can retrieve a specific open database using the FindOpenDatabase method.

In order to make changes to a database, it must be locked using the LockDb method. Any changes you make can be saved or rolled back using the UnlockDb method. UnLockDb has a Boolean commit parameter that controls this behavior. If the value of the commit parameter is true, then the changes will be written to the file. If you pass in false for the commit parameter, the changes will be rolled back or undone by reloading the database from disk.

Warning: When you unlock without commiting changes, the database is reloaded, all object instances in the database are cleared, and new objects are created as the database is read in. This means that any pointers to database-resident objects are invalid after the database has been reloaded. If you need to access database-resident objects across lock and unlock boundaries, you should store the object ID instead of a direct pointer to the object. The object ID (IAcSmObjectId) provides a means of safely referencing an object within the sheet set database. You can retrieve the object ID of any database resident object by calling the GetObjectId method on the object. Conversely, you can get the associated object instance from an ID by calling the GetPeristentObject method.


Add a Sheet Set to a Database [Sheet Set Objects Reference: SSO]

Add a Sheet Set to a Database

To add a sheet set to a sheet set database, you use a locked AcSmDatabase object and the GetSheetSet method to get an AcSmSheetSet object. With the AcSmSheetSet object, you can perform operations such as adding a name and description to the sheet set.

To add a sheet to an AcSmSheetSet object, you use the AddNewSheet method or the ImportSheet method. If you use the ImportSheet method, you create an AcSmNamedAcDbObjectReference object with the appropriate file name and layout name. After calling the ImportSheet method, you must call the InsertComponent method to finish the import.


Reliably Access Sheet Set Components [Sheet Set Objects Reference: SSO]

Reliably Access Sheet Set Components

You can use the Do While structure in VBA for reliable access to sheet set components. The Microsoft Help for VBA contains examples of the Do While structure. The Microsoft Help for VBA is available from the Help menu in the VBA IDE.

To use the Do While structure to access sheet set components, you use a statement similar to Do While Not obj Is Nothing to determine if an object is available. For example, to use a Do While Not obj Is Nothing statement to iterate through objects in a collection, you could use the following code:

Public Function FindAllComponents(comps As Collection) As Boolean
    On Local Error GoTo etrap
    If comps Is Nothing Then Set comps = New Collection
    Dim iter As IAcSmEnumPersist
    Set iter = m_db.GetEnumerator
    Dim obj As IAcSmPersist
    Set obj = iter.Next
    Do While Not obj Is Nothing
        If TypeOf obj Is IAcSmComponent Then
            Dim comp As IAcSmComponent
            Set comp = obj
            comps.Add comp
        End If
        Set obj = iter.Next
    Loop
    FindAllComponents = True
    Exit Function
etrap:
    MsgBox CStr(Err.Number) & " - " & Err.Description
End Function

For an additional example of using the Do While structure in VBA to access sheet set components, see the sample VBA project in the following folder: C:\Program Files\AutoCAD 2007\Sample\ActiveX\SheetSetVBA.


Create a Subset [Sheet Set Objects Reference: SSO]

Create a Subset

You can create a subset (or nested subset) in a sheet set.

To create a subset, you use the CreateSubset method of the AcSmSheetSet object. The CreateSubset method creates an AcSmSubset object.

After an AcSmSubset object is created, you can add sheets to it. Create an AcSmSheetSet object and use the AddNewSheet method or the ImportSheet method. If you use the ImportSheet method, you create an AcSmNamedAcDbObjectReference object with the appropriate file name and layout name. After calling the ImportSheet method, you must call the InsertComponent method to finish the import.


Add Custom Data [Sheet Set Objects Reference: SSO]

Add Custom Data

To add a custom property to a sheet set, you use the GetCustomPropertyBag method of the AcSmSheet object to create an AcSmCustomPropertyBag object. Then use the SetProperty method to set a custom property value. If you add a custom property to a sheet set and set the property flag to CUSTOM_SHEET_PROP, sheets that are within subsets of the sheet set inherit the property.


Objects [Sheet Set Objects Reference: SSO]

Objects
  • A Objects
  • I Objects
  • P Objects


A Objects
AcSmAcDbBlockRecordReference

AcSmAcDbDatabase

AcSmAcDbLayoutReference

AcSmAcDbObjectReference

AcSmAcDbViewReference

AcSmCalloutBlockReferences

AcSmCalloutBlocks

AcSmCustomPropertyBag

AcSmCustomPropertyValue

AcSmDatabase

AcSmDSTFiler

AcSmEvent

AcSmFileReference

AcSmNamedAcDbObjectReference

AcSmObjectReference

AcSmPersistProxy

AcSmPublishOptions

AcSmResources

AcSmSheet

AcSmSheetSelSet

AcSmSheetSelSets

AcSmSheetSet

AcSmSheetSetMgr

AcSmSheetView

AcSmSheetViews

AcSmSubset

AcSmViewCategories

AcSmViewCategory

Comments?


I Objects
IAcSmComponent

IAcSmEnumAcDbBlockRecordReference

IAcSmEnumComponent

IAcSmEnumDatabase

IAcSmEnumFileReference

IAcSmEnumPersist

IAcSmEnumProperty

IAcSmEnumSheetSelSet

IAcSmEnumSheetView

IAcSmEnumViewCategory

IAcSmEvents

IAcSmObjectId

IAcSmPersist


P Objects
PropertyFlags


Methods [Sheet Set Objects Reference: SSO]

Methods
  • A Methods
  • C Methods
  • F Methods
  • G Methods
  • I Methods
  • L Methods
  • N Methods
  • O Methods
  • P Methods
  • R Methods
  • S Methods
  • U Methods
  • W Methods


A Methods
Add (AcSmCalloutBlockReferences)

Add (AcSmCalloutBlocks)

Add (AcSmResources)

Add (AcSmSheetSelSet)

Add (AcSmSheetSelSets)

AddNewSheet (AcSmSheetSet)

AddNewSheet (AcSmSubset)


C Methods
Clear (AcSmAcDbBlockRecordReference)

Clear (AcSmAcDbLayoutReference)

Clear (AcSmAcDbObjectReference)

Clear (AcSmAcDbViewReference)

Clear (AcSmCalloutBlockReferences)

Clear (AcSmCalloutBlocks)

Clear (AcSmCustomPropertyBag)

Clear (AcSmCustomPropertyValue)

Clear (AcSmDatabase)

Clear (AcSmFileReference)

Clear (AcSmNamedAcDbObjectReference)

Clear (AcSmObjectReference)

Clear (AcSmPersistProxy)

Clear (AcSmPublishOptions)

Clear (AcSmResources)

Clear (AcSmSheet)

Clear (AcSmSheetSelSet)

Clear (AcSmSheetSelSets)

Clear (AcSmSheetSet)

Clear (AcSmSheetView)

Clear (AcSmSheetViews)

Clear (AcSmSubset)

Clear (AcSmViewCategories)

Clear (AcSmViewCategory)

Clear (IAcSmComponent)

Clear (IAcSmPersist)

Close (AcSmDSTFiler)

Close (AcSmSheetSetMgr)

CloseAll (AcSmSheetSetMgr)

CreateDatabase (AcSmSheetSetMgr)

CreateSubset (AcSmSheetSet)

CreateSubset (AcSmSubset)

CreateViewCategory (AcSmViewCategories)


F Methods
FindObject (AcSmDatabase)

FindOpenDatabase (AcSmSheetSetMgr)


G Methods
GetAcDbDatabase (AcSmAcDbDatabase)

GetAcDbHandle (AcSmAcDbBlockRecordReference)

GetAcDbHandle (AcSmAcDbLayoutReference)

GetAcDbHandle (AcSmAcDbObjectReference)

GetAcDbHandle (AcSmAcDbViewReference)

GetAcDbHandle (AcSmNamedAcDbObjectReference)

GetAcSmAcDbDatabase (AcSmAcDbBlockRecordReference)

GetAcSmAcDbDatabase (AcSmAcDbLayoutReference)

GetAcSmAcDbDatabase (AcSmAcDbObjectReference)

GetAcSmAcDbDatabase (AcSmAcDbViewReference)

GetAcSmAcDbDatabase (AcSmNamedAcDbObjectReference)

GetAltPageSetups (AcSmSheetSet)

GetCalloutBlocks (AcSmSheetSet)

GetCalloutBlocks (AcSmViewCategory)

GetCategory (AcSmSheet)

GetCategory (AcSmSheetView)

GetCurrentObject (AcSmDSTFiler)

GetCurrentObjectHeaderInfo (AcSmDSTFiler)

GetCustomPropertyBag (AcSmCalloutBlockReferences)

GetCustomPropertyBag (AcSmCalloutBlocks)

GetCustomPropertyBag (AcSmDatabase)

GetCustomPropertyBag (AcSmResources)

GetCustomPropertyBag (AcSmSheet)

GetCustomPropertyBag (AcSmSheetSelSet)

GetCustomPropertyBag (AcSmSheetSelSets)

GetCustomPropertyBag (AcSmSheetSet)

GetCustomPropertyBag (AcSmSheetView)

GetCustomPropertyBag (AcSmSheetViews)

GetCustomPropertyBag (AcSmSubset)

GetCustomPropertyBag (AcSmViewCategories)

GetCustomPropertyBag (AcSmViewCategory)

GetCustomPropertyBag (IAcSmComponent)

GetDatabase (AcSmAcDbBlockRecordReference)

GetDatabase (AcSmAcDbLayoutReference)

GetDatabase (AcSmAcDbObjectReference)

GetDatabase (AcSmAcDbViewReference)

GetDatabase (AcSmCalloutBlockReferences)

GetDatabase (AcSmCalloutBlocks)

GetDatabase (AcSmCustomPropertyBag)

GetDatabase (AcSmCustomPropertyValue)

GetDatabase (AcSmDatabase)

GetDatabase (AcSmDSTFiler)

GetDatabase (AcSmFileReference)

GetDatabase (AcSmNamedAcDbObjectReference)

GetDatabase (AcSmObjectReference)

GetDatabase (AcSmPersistProxy)

GetDatabase (AcSmPublishOptions)

GetDatabase (AcSmResources)

GetDatabase (AcSmSheet)

GetDatabase (AcSmSheetSelSet)

GetDatabase (AcSmSheetSelSets)

GetDatabase (AcSmSheetSet)

GetDatabase (AcSmSheetView)

GetDatabase (AcSmSheetViews)

GetDatabase (AcSmSubset)

GetDatabase (AcSmViewCategories)

GetDatabase (AcSmViewCategory)

GetDatabase (IAcSmComponent)

GetDatabase (IAcSmObjectId)

GetDatabase (IAcSmPersist)

GetDatabaseEnumerator (AcSmSheetSetMgr)

GetDbVersion (AcSmDatabase)

GetDefAltPageSetup (AcSmSheetSet)

GetDefaultOutputdir (AcSmPublishOptions)

GetDefaultViewCategory (AcSmViewCategories)

GetDefDwtLayout (AcSmSheetSet)

GetDefDwtLayout (AcSmSubset)

GetDefLabelBlk (AcSmSheetSet)

GetDesc (AcSmCalloutBlockReferences)

GetDesc (AcSmCalloutBlocks)

GetDesc (AcSmDatabase)

GetDesc (AcSmResources)

GetDesc (AcSmSheet)

GetDesc (AcSmSheetSelSet)

GetDesc (AcSmSheetSelSets)

GetDesc (AcSmSheetSet)

GetDesc (AcSmSheetView)

GetDesc (AcSmSheetViews)

GetDesc (AcSmSubset)

GetDesc (AcSmViewCategories)

GetDesc (AcSmViewCategory)

GetDesc (IAcSmComponent)

GetDirectlyOwnedObjects (AcSmAcDbBlockRecordReference)

GetDirectlyOwnedObjects (AcSmAcDbLayoutReference)

GetDirectlyOwnedObjects (AcSmAcDbObjectReference)

GetDirectlyOwnedObjects (AcSmAcDbViewReference)

GetDirectlyOwnedObjects (AcSmCalloutBlockReferences)

GetDirectlyOwnedObjects (AcSmCalloutBlocks)

GetDirectlyOwnedObjects (AcSmCustomPropertyBag)

GetDirectlyOwnedObjects (AcSmCustomPropertyValue)

GetDirectlyOwnedObjects (AcSmDatabase)

GetDirectlyOwnedObjects (AcSmFileReference)

GetDirectlyOwnedObjects (AcSmNamedAcDbObjectReference)

GetDirectlyOwnedObjects (AcSmObjectReference)

GetDirectlyOwnedObjects (AcSmPersistProxy)

GetDirectlyOwnedObjects (AcSmPublishOptions)

GetDirectlyOwnedObjects (AcSmResources)

GetDirectlyOwnedObjects (AcSmSheet)

GetDirectlyOwnedObjects (AcSmSheetSelSet)

GetDirectlyOwnedObjects (AcSmSheetSelSets)

GetDirectlyOwnedObjects (AcSmSheetSet)

GetDirectlyOwnedObjects (AcSmSheetView)

GetDirectlyOwnedObjects (AcSmSheetViews)

GetDirectlyOwnedObjects (AcSmSubset)

GetDirectlyOwnedObjects (AcSmViewCategories)

GetDirectlyOwnedObjects (AcSmViewCategory)

GetDirectlyOwnedObjects (IAcSmComponent)

GetDirectlyOwnedObjects (IAcSmPersist)

GetDoNotPlot (AcSmSheet)

GetDwfType (AcSmPublishOptions)

GetEnumerator (AcSmCalloutBlockReferences)

GetEnumerator (AcSmCalloutBlocks)

GetEnumerator (AcSmDatabase)

GetEnumerator (AcSmResources)

GetEnumerator (AcSmSheetSelSet)

GetEnumerator (AcSmSheetSelSets)

GetEnumerator (AcSmSheetViews)

GetEnumerator (AcSmViewCategories)

GetFileName (AcSmAcDbBlockRecordReference)

GetFileName (AcSmAcDbLayoutReference)

GetFileName (AcSmAcDbObjectReference)

GetFileName (AcSmAcDbViewReference)

GetFileName (AcSmDatabase)

GetFileName (AcSmFileReference)

GetFileName (AcSmNamedAcDbObjectReference)

GetFlags (AcSmCustomPropertyValue)

GetHandle (IAcSmObjectId)

GetIAcadDatabase (AcSmAcDbDatabase)

GetIncludePlotStamp (AcSmPublishOptions)

GetIsDirty (AcSmAcDbBlockRecordReference)

GetIsDirty (AcSmAcDbLayoutReference)

GetIsDirty (AcSmAcDbObjectReference)

GetIsDirty (AcSmAcDbViewReference)

GetIsDirty (AcSmCalloutBlockReferences)

GetIsDirty (AcSmCalloutBlocks)

GetIsDirty (AcSmCustomPropertyBag)

GetIsDirty (AcSmCustomPropertyValue)

GetIsDirty (AcSmDatabase)

GetIsDirty (AcSmFileReference)

GetIsDirty (AcSmNamedAcDbObjectReference)

GetIsDirty (AcSmObjectReference)

GetIsDirty (AcSmPersistProxy)

GetIsDirty (AcSmPublishOptions)

GetIsDirty (AcSmResources)

GetIsDirty (AcSmSheet)

GetIsDirty (AcSmSheetSelSet)

GetIsDirty (AcSmSheetSelSets)

GetIsDirty (AcSmSheetSet)

GetIsDirty (AcSmSheetView)

GetIsDirty (AcSmSheetViews)

GetIsDirty (AcSmSubset)

GetIsDirty (AcSmViewCategories)

GetIsDirty (AcSmViewCategory)

GetIsDirty (IAcSmComponent)

GetIsDirty (IAcSmPersist)

GetIssuePurpose (AcSmSheet)

GetIsTemporary (AcSmDatabase)

GetLayerInfo (AcSmPublishOptions)

GetLayout (AcSmSheet)

GetLockOwnerInfo (AcSmDatabase)

GetLockStatus (AcSmDatabase)

GetName (AcSmAcDbBlockRecordReference)

GetName (AcSmAcDbLayoutReference)

GetName (AcSmAcDbViewReference)

GetName (AcSmCalloutBlockReferences)

GetName (AcSmCalloutBlocks)

GetName (AcSmDatabase)

GetName (AcSmNamedAcDbObjectReference)

GetName (AcSmResources)

GetName (AcSmSheet)

GetName (AcSmSheetSelSet)

GetName (AcSmSheetSelSets)

GetName (AcSmSheetSet)

GetName (AcSmSheetView)

GetName (AcSmSheetViews)

GetName (AcSmSubset)

GetName (AcSmViewCategories)

GetName (AcSmViewCategory)

GetName (IAcSmComponent)

GetNamedView (AcSmSheetView)

GetNewObjectId (AcSmDatabase)

GetNewSheetLocation (AcSmSheetSet)

GetNewSheetLocation (AcSmSubset)

GetNumber (AcSmSheet)

GetNumber (AcSmSheetView)

GetObjectId (AcSmAcDbBlockRecordReference)

GetObjectId (AcSmAcDbLayoutReference)

GetObjectId (AcSmAcDbObjectReference)

GetObjectId (AcSmAcDbViewReference)

GetObjectId (AcSmCalloutBlockReferences)

GetObjectId (AcSmCalloutBlocks)

GetObjectId (AcSmCustomPropertyBag)

GetObjectId (AcSmCustomPropertyValue)

GetObjectId (AcSmDatabase)

GetObjectId (AcSmFileReference)

GetObjectId (AcSmNamedAcDbObjectReference)

GetObjectId (AcSmObjectReference)

GetObjectId (AcSmPersistProxy)

GetObjectId (AcSmPublishOptions)

GetObjectId (AcSmResources)

GetObjectId (AcSmSheet)

GetObjectId (AcSmSheetSelSet)

GetObjectId (AcSmSheetSelSets)

GetObjectId (AcSmSheetSet)

GetObjectId (AcSmSheetView)

GetObjectId (AcSmSheetViews)

GetObjectId (AcSmSubset)

GetObjectId (AcSmViewCategories)

GetObjectId (AcSmViewCategory)

GetObjectId (IAcSmComponent)

GetObjectId (IAcSmPersist)

GetOutputFileName (AcSmPublishOptions)

GetOwner (AcSmAcDbBlockRecordReference)

GetOwner (AcSmAcDbLayoutReference)

GetOwner (AcSmAcDbObjectReference)

GetOwner (AcSmAcDbViewReference)

GetOwner (AcSmCalloutBlockReferences)

GetOwner (AcSmCalloutBlocks)

GetOwner (AcSmCustomPropertyBag)

GetOwner (AcSmCustomPropertyValue)

GetOwner (AcSmDatabase)

GetOwner (AcSmFileReference)

GetOwner (AcSmNamedAcDbObjectReference)

GetOwner (AcSmObjectReference)

GetOwner (AcSmPersistProxy)

GetOwner (AcSmPublishOptions)

GetOwner (AcSmResources)

GetOwner (AcSmSheet)

GetOwner (AcSmSheetSelSet)

GetOwner (AcSmSheetSelSets)

GetOwner (AcSmSheetSet)

GetOwner (AcSmSheetView)

GetOwner (AcSmSheetViews)

GetOwner (AcSmSubset)

GetOwner (AcSmViewCategories)

GetOwner (AcSmViewCategory)

GetOwner (IAcSmComponent)

GetOwner (IAcSmObjectId)

GetOwner (IAcSmPersist)

GetOwnerAcDbHandle (AcSmAcDbBlockRecordReference)

GetOwnerAcDbHandle (AcSmAcDbLayoutReference)

GetOwnerAcDbHandle (AcSmAcDbViewReference)

GetOwnerAcDbHandle (AcSmNamedAcDbObjectReference)

GetParentSheetSet (AcSmSheetSetMgr)

GetPassword (AcSmPublishOptions)

GetPersistObject (IAcSmObjectId)

GetProjectMilestone (AcSmSheetSet)

GetProjectName (AcSmSheetSet)

GetProjectNumber (AcSmSheetSet)

GetProjectPhase (AcSmSheetSet)

GetPromptForDwgName (AcSmSheetSet)

GetPromptForDwt (AcSmSheetSet)

GetPromptForDwt (AcSmSubset)

GetPromptForName (AcSmPublishOptions)

GetPromptForPassword (AcSmPublishOptions)

GetProperty (AcSmCustomPropertyBag)

GetPropertyEnumerator (AcSmCustomPropertyBag)

GetPublishOptions (AcSmSheetSet)

GetReferencedObject (AcSmObjectReference)

GetReferenceFlags (AcSmObjectReference)

GetResources (AcSmSheetSet)

GetRevisionDate (AcSmSheet)

GetRevisionNumber (AcSmDSTFiler)

GetRevisionNumber (AcSmSheet)

GetSheetEnumerator (AcSmSheetSet)

GetSheetEnumerator (AcSmSubset)

GetSheetSelSets (AcSmSheetSet)

GetSheetSet (AcSmDatabase)

GetSheetViewEnumerator (AcSmViewCategory)

GetSheetViews (AcSmSheet)

GetTemplateDstFileName (AcSmDatabase)

GetTitle (AcSmSheet)

GetTitle (AcSmSheetView)

GetTypeName (AcSmAcDbBlockRecordReference)

GetTypeName (AcSmAcDbLayoutReference)

GetTypeName (AcSmAcDbObjectReference)

GetTypeName (AcSmAcDbViewReference)

GetTypeName (AcSmCalloutBlockReferences)

GetTypeName (AcSmCalloutBlocks)

GetTypeName (AcSmCustomPropertyBag)

GetTypeName (AcSmCustomPropertyValue)

GetTypeName (AcSmDatabase)

GetTypeName (AcSmFileReference)

GetTypeName (AcSmNamedAcDbObjectReference)

GetTypeName (AcSmObjectReference)

GetTypeName (AcSmPersistProxy)

GetTypeName (AcSmPublishOptions)

GetTypeName (AcSmResources)

GetTypeName (AcSmSheet)

GetTypeName (AcSmSheetSelSet)

GetTypeName (AcSmSheetSelSets)

GetTypeName (AcSmSheetSet)

GetTypeName (AcSmSheetView)

GetTypeName (AcSmSheetViews)

GetTypeName (AcSmSubset)

GetTypeName (AcSmViewCategories)

GetTypeName (AcSmViewCategory)

GetTypeName (IAcSmComponent)

GetTypeName (IAcSmPersist)

GetUnrecognizedData (AcSmPublishOptions)

GetUnrecognizedSections (AcSmPublishOptions)

GetUsePassword (AcSmPublishOptions)

GetValue (AcSmCustomPropertyValue)

GetViewCategories (AcSmSheetSet)


I Methods
ImportSheet (AcSmSheetSet)

ImportSheet (AcSmSubset)

Init (AcSmDSTFiler)

InitNew (AcSmAcDbBlockRecordReference)

InitNew (AcSmAcDbLayoutReference)

InitNew (AcSmAcDbObjectReference)

InitNew (AcSmAcDbViewReference)

InitNew (AcSmCalloutBlockReferences)

InitNew (AcSmCalloutBlocks)

InitNew (AcSmCustomPropertyBag)

InitNew (AcSmCustomPropertyValue)

InitNew (AcSmDatabase)

InitNew (AcSmFileReference)

InitNew (AcSmNamedAcDbObjectReference)

InitNew (AcSmObjectReference)

InitNew (AcSmPersistProxy)

InitNew (AcSmPublishOptions)

InitNew (AcSmResources)

InitNew (AcSmSheet)

InitNew (AcSmSheetSelSet)

InitNew (AcSmSheetSelSets)

InitNew (AcSmSheetSet)

InitNew (AcSmSheetView)

InitNew (AcSmSheetViews)

InitNew (AcSmSubset)

InitNew (AcSmViewCategories)

InitNew (AcSmViewCategory)

InitNew (IAcSmComponent)

InitNew (IAcSmPersist)

InsertComponent (AcSmSheetSet)

InsertComponent (AcSmSubset)

InsertComponentAfter (AcSmSheetSet)

InsertComponentAfter (AcSmSubset)

IsEqual (IAcSmObjectId)

IsValid (IAcSmObjectId)


L Methods
Load (AcSmAcDbBlockRecordReference)

Load (AcSmAcDbLayoutReference)

Load (AcSmAcDbObjectReference)

Load (AcSmAcDbViewReference)

Load (AcSmCalloutBlockReferences)

Load (AcSmCalloutBlocks)

Load (AcSmCustomPropertyBag)

Load (AcSmCustomPropertyValue)

Load (AcSmDatabase)

Load (AcSmFileReference)

Load (AcSmNamedAcDbObjectReference)

Load (AcSmObjectReference)

Load (AcSmPersistProxy)

Load (AcSmPublishOptions)

Load (AcSmResources)

Load (AcSmSheet)

Load (AcSmSheetSelSet)

Load (AcSmSheetSelSets)

Load (AcSmSheetSet)

Load (AcSmSheetView)

Load (AcSmSheetViews)

Load (AcSmSubset)

Load (AcSmViewCategories)

Load (AcSmViewCategory)

Load (IAcSmComponent)

Load (IAcSmPersist)

LoadFromFile (AcSmDatabase)

LockDb (AcSmDatabase)


N Methods
Next (IAcSmEnumAcDbBlockRecordReference)

Next (IAcSmEnumComponent)

Next (IAcSmEnumDatabase)

Next (IAcSmEnumFileReference)

Next (IAcSmEnumPersist)

Next (IAcSmEnumProperty)

Next (IAcSmEnumSheetSelSet)

Next (IAcSmEnumSheetView)

Next (IAcSmEnumViewCategory)

NotifyRegisteredEventHandlers (AcSmDatabase)

NotifyRegisteredEventHandlers (AcSmSheetSet)

NotifyRegisteredEventHandlers (AcSmSubset)


O Methods
OnChanged (IAcSmEvents)

OpenDatabase (AcSmSheetSetMgr)


P Methods
PopCurrentReadObject (AcSmDSTFiler)

PopCurrentWriteObject (AcSmDSTFiler)

PushCurrentReadObject (AcSmDSTFiler)

PushCurrentWriteObject (AcSmDSTFiler)


R Methods
ReadObject (AcSmDSTFiler)

ReadProperty (AcSmDSTFiler)

ReadRawData (AcSmDSTFiler)

Register (AcSmDatabase)

Register (AcSmSheetSet)

Register (AcSmSheetSetMgr)

RegisterOwner (AcSmDatabase)

Remove (AcSmCalloutBlockReferences)

Remove (AcSmCalloutBlocks)

Remove (AcSmResources)

Remove (AcSmSheetSelSet)

Remove (AcSmSheetSelSets)

RemoveSheet (AcSmSheetSet)

RemoveSheet (AcSmSubset)

RemoveSubset (AcSmSheetSet)

RemoveSubset (AcSmSubset)

RemoveViewCategory (AcSmViewCategories)

Reset (IAcSmEnumAcDbBlockRecordReference)

Reset (IAcSmEnumComponent)

Reset (IAcSmEnumDatabase)

Reset (IAcSmEnumFileReference)

Reset (IAcSmEnumPersist)

Reset (IAcSmEnumProperty)

Reset (IAcSmEnumSheetSelSet)

Reset (IAcSmEnumSheetView)

Reset (IAcSmEnumViewCategory)

ResolveAcDbObject (AcSmAcDbBlockRecordReference)

ResolveAcDbObject (AcSmAcDbLayoutReference)

ResolveAcDbObject (AcSmAcDbObjectReference)

ResolveAcDbObject (AcSmAcDbViewReference)

ResolveAcDbObject (AcSmNamedAcDbObjectReference)

ResolveFileName (AcSmAcDbBlockRecordReference)

ResolveFileName (AcSmAcDbLayoutReference)

ResolveFileName (AcSmAcDbObjectReference)

ResolveFileName (AcSmAcDbViewReference)

ResolveFileName (AcSmFileReference)

ResolveFileName (AcSmNamedAcDbObjectReference)


S Methods
Save (AcSmAcDbBlockRecordReference)

Save (AcSmAcDbLayoutReference)

Save (AcSmAcDbObjectReference)

Save (AcSmAcDbViewReference)

Save (AcSmCalloutBlockReferences)

Save (AcSmCalloutBlocks)

Save (AcSmCustomPropertyBag)

Save (AcSmCustomPropertyValue)

Save (AcSmDatabase)

Save (AcSmFileReference)

Save (AcSmNamedAcDbObjectReference)

Save (AcSmObjectReference)

Save (AcSmPersistProxy)

Save (AcSmPublishOptions)

Save (AcSmResources)

Save (AcSmSheet)

Save (AcSmSheetSelSet)

Save (AcSmSheetSelSets)

Save (AcSmSheetSet)

Save (AcSmSheetView)

Save (AcSmSheetViews)

Save (AcSmSubset)

Save (AcSmViewCategories)

Save (AcSmViewCategory)

Save (IAcSmComponent)

Save (IAcSmPersist)

SetAcDbHandle (AcSmAcDbBlockRecordReference)

SetAcDbHandle (AcSmAcDbLayoutReference)

SetAcDbHandle (AcSmAcDbObjectReference)

SetAcDbHandle (AcSmAcDbViewReference)

SetAcDbHandle (AcSmNamedAcDbObjectReference)

SetAcDbObject (AcSmAcDbBlockRecordReference)

SetAcDbObject (AcSmAcDbLayoutReference)

SetAcDbObject (AcSmAcDbObjectReference)

SetAcDbObject (AcSmAcDbViewReference)

SetAcDbObject (AcSmNamedAcDbObjectReference)

SetAltPageSetups (AcSmSheetSet)

SetCategory (AcSmSheet)

SetCategory (AcSmSheetView)

SetDefAltPageSetup (AcSmSheetSet)

SetDefaultOutputdir (AcSmPublishOptions)

SetDefDwtLayout (AcSmSheetSet)

SetDefDwtLayout (AcSmSubset)

SetDefLabelBlk (AcSmSheetSet)

SetDesc (AcSmCalloutBlockReferences)

SetDesc (AcSmCalloutBlocks)

SetDesc (AcSmDatabase)

SetDesc (AcSmResources)

SetDesc (AcSmSheet)

SetDesc (AcSmSheetSelSet)

SetDesc (AcSmSheetSelSets)

SetDesc (AcSmSheetSet)

SetDesc (AcSmSheetView)

SetDesc (AcSmSheetViews)

SetDesc (AcSmSubset)

SetDesc (AcSmViewCategories)

SetDesc (AcSmViewCategory)

SetDesc (IAcSmComponent)

SetDoNotPlot (AcSmSheet)

SetDwfType (AcSmPublishOptions)

SetFileName (AcSmAcDbBlockRecordReference)

SetFileName (AcSmAcDbLayoutReference)

SetFileName (AcSmAcDbObjectReference)

SetFileName (AcSmAcDbViewReference)

SetFileName (AcSmDatabase)

SetFileName (AcSmFileReference)

SetFileName (AcSmNamedAcDbObjectReference)

SetFlags (AcSmCustomPropertyValue)

SetIncludePlotStamp (AcSmPublishOptions)

SetIssuePurpose (AcSmSheet)

SetIsTemporary (AcSmDatabase)

SetLayerInfo (AcSmPublishOptions)

SetLayout (AcSmSheet)

SetName (AcSmAcDbBlockRecordReference)

SetName (AcSmAcDbLayoutReference)

SetName (AcSmAcDbViewReference)

SetName (AcSmCalloutBlockReferences)

SetName (AcSmCalloutBlocks)

SetName (AcSmDatabase)

SetName (AcSmNamedAcDbObjectReference)

SetName (AcSmResources)

SetName (AcSmSheet)

SetName (AcSmSheetSelSet)

SetName (AcSmSheetSelSets)

SetName (AcSmSheetSet)

SetName (AcSmSheetView)

SetName (AcSmSheetViews)

SetName (AcSmSubset)

SetName (AcSmViewCategories)

SetName (AcSmViewCategory)

SetName (IAcSmComponent)

SetNamedView (AcSmSheetView)

SetNewSheetLocation (AcSmSheetSet)

SetNewSheetLocation (AcSmSubset)

SetNumber (AcSmSheet)

SetNumber (AcSmSheetView)

SetOutputFileName (AcSmPublishOptions)

SetOwner (AcSmAcDbBlockRecordReference)

SetOwner (AcSmAcDbLayoutReference)

SetOwner (AcSmAcDbObjectReference)

SetOwner (AcSmAcDbViewReference)

SetOwner (AcSmCalloutBlockReferences)

SetOwner (AcSmCalloutBlocks)

SetOwner (AcSmCustomPropertyBag)

SetOwner (AcSmCustomPropertyValue)

SetOwner (AcSmDatabase)

SetOwner (AcSmFileReference)

SetOwner (AcSmNamedAcDbObjectReference)

SetOwner (AcSmObjectReference)

SetOwner (AcSmPersistProxy)

SetOwner (AcSmPublishOptions)

SetOwner (AcSmResources)

SetOwner (AcSmSheet)

SetOwner (AcSmSheetSelSet)

SetOwner (AcSmSheetSelSets)

SetOwner (AcSmSheetSet)

SetOwner (AcSmSheetView)

SetOwner (AcSmSheetViews)

SetOwner (AcSmSubset)

SetOwner (AcSmViewCategories)

SetOwner (AcSmViewCategory)

SetOwner (IAcSmComponent)

SetOwner (IAcSmPersist)

SetOwnerAcDbHandle (AcSmAcDbBlockRecordReference)

SetOwnerAcDbHandle (AcSmAcDbLayoutReference)

SetOwnerAcDbHandle (AcSmAcDbViewReference)

SetOwnerAcDbHandle (AcSmNamedAcDbObjectReference)

SetPassword (AcSmPublishOptions)

SetProjectMilestone (AcSmSheetSet)

SetProjectName (AcSmSheetSet)

SetProjectNumber (AcSmSheetSet)

SetProjectPhase (AcSmSheetSet)

SetPromptForDwgName (AcSmSheetSet)

SetPromptForDwt (AcSmSheetSet)

SetPromptForDwt (AcSmSubset)

SetPromptForName (AcSmPublishOptions)

SetPromptForPassword (AcSmPublishOptions)

SetProperty (AcSmCustomPropertyBag)

SetReferencedObject (AcSmObjectReference)

SetReferenceFlags (AcSmObjectReference)

SetRevisionDate (AcSmSheet)

SetRevisionNumber (AcSmSheet)

SetTitle (AcSmSheet)

SetTitle (AcSmSheetView)

SetTypeName (AcSmPersistProxy)

SetUnrecognizedData (AcSmPublishOptions)

SetUnrecognizedSections (AcSmPublishOptions)

SetUsePassword (AcSmPublishOptions)

SetValue (AcSmCustomPropertyValue)

Sync (AcSmSheetSet)

Sync (AcSmSheetViews)


U Methods
UnlockDb (AcSmDatabase)

Unregister (AcSmDatabase)

Unregister (AcSmSheetSet)

Unregister (AcSmSheetSetMgr)

UpdateInMemoryDwgHints (AcSmDatabase)

UpdateInMemoryDwgHints (AcSmSheetSet)

UpdateInMemoryDwgHints (AcSmSubset)


W Methods
WriteObject (AcSmDSTFiler)

WriteProperty (AcSmDSTFiler)

WriteRawData (AcSmDSTFiler)


Properties [Sheet Set Objects Reference: SSO]

Properties
  • A Properties
  • C Properties
  • E Properties
  • M Properties
  • S Properties


A Properties
ACSM (DATABASE_CHANGED_AcSmEvent)

ACSM (DATABASE_CREATED_AcSmEvent)

ACSM (DATABASE_IS_CLOSING_AcSmEvent)

ACSM (DATABASE_LOAD_BEGIN_AcSmEvent)

ACSM (DATABASE_LOAD_COMPLETE_AcSmEvent)

ACSM (DATABASE_LOAD_FAILED_AcSmEvent)

ACSM (DATABASE_LOCKED_AcSmEvent)

ACSM (DATABASE_OPENED_AcSmEvent)

ACSM (DATABASE_UNLOCKED_AcSmEvent)


C Properties
CALLOUT (BLOCK_ADDED_AcSmEvent)

CALLOUT (BLOCK_DELETED_AcSmEvent)

CUSTOM (SHEET_PROP_PropertyFlags)


E Properties
EMPTY (PropertyFlags)


M Properties
MODEL (RESOURCE_ADDED_AcSmEvent)

MODEL (RESOURCE_DELETED_AcSmEvent)


S Properties
SHEET (ADDED_AcSmEvent)

SHEET (DELETED_AcSmEvent)

SHEET (SELECTION_SET_CREATED_AcSmEvent)

SHEET (SELECTION_SET_DELETED_AcSmEvent)

SHEET (SUBSET_CREATED_AcSmEvent)

SHEET (SUBSET_DELETED_AcSmEvent)

SHEET (VIEW_CATEGORY_CREATED_AcSmEvent)

SHEET (VIEW_CATEGORY_DELETED_AcSmEvent)

SHEET (VIEW_CREATED_AcSmEvent)

SHEET (VIEW_DELETED_AcSmEvent)

SHEETS (RENUMBERED_AcSmEvent)


Enums [Sheet Set Objects Reference: SSO]

Enums
  • A Enums


A Enums
AcSmLockStatus

AcSmObjectReferenceFlags


Comments?

Using this form sends your comments to the Autodesk Technical Publications group responsible for this documentation.

Topic title and location:
Name (optional):
Email (optional):
Comments:

Note: This form is not intended as a way for you to receive feedback or technical support. The information you provide will be used to enhance future updates to the documentation. Thanks!


zz [Blank Topic]

Blank Topic

This topic intentionally left blank.


AcSmLockStatus

Lock status of an IAcSmDatabase, based on bitcode values.

AcSmLockStatus
Name | Value | Description
AcSmLockStatus_Locked_Local | 1 | The database is locked and open for write access.
AcSmLockStatus_Locked_ReadOnly | 4 | Write access to the database is denied because it is read-only.
AcSmLockStatus_Locked_Remote | 2 | Write access to the database is denied because it is remote.
AcSmLockStatus_UnLocked | 0 | Write access to the database is denied because it was not locked.
AcSmLockStatus_Locked_AccessDenied | 16 | Access to the database is denied due to lack of rights for access.
AcSmLockStatus_Locked_NotConnected | 8 | Access to the database is denied due to a lost connection to the database.


AcSmObjectReferenceFlags

The kind of referencing provided by an IAcSmObjectReference. An IAcSmObjectReference is used to create an object reference from one component to another.

AcSmObjectReferenceFlags
Name | Value | Description
AcSmObjectReference_HardPointer | 2 | The referenced object is essential to the existence of the object that refers to it.
AcSmObjectReference_SoftPointer | 1 | The referenced object is not essential to the existence of the object that refers to it.


AcSmCalloutBlockReferences.Add

Up a level to AcSmCalloutBlockReferences
AcSmCalloutBlockReferences.Add Method

Appends the provided AcSmAcDbBlockRecordReference component to the collection.

Syntax

Add(

pBlkRef As IAcSmAcDbBlockRecordReference) As Object

pBlkRef Input block reference


AcSmCalloutBlocks.Add

Up a level to AcSmCalloutBlocks
AcSmCalloutBlocks.Add Method

Appends an IAcSmAcDbBlockRecordReference component to the collection.

Syntax

Add(

pBlkRef As IAcSmAcDbBlockRecordReference) As Object

pBlkRef Input pointer to an IAcSmAcDbBlockRecordReference component to add to the collection


AcSmResources.Add

Up a level to AcSmResources
AcSmResources.Add Method

Appends an IAcSmFileReference component to the collection.

Syntax

Add(

pResource As IAcSmFileReference) As Object

pResource Input IAcSmFileReference component to add to the collection


AcSmSheetSelSet.Add

Up a level to AcSmSheetSelSet
AcSmSheetSelSet.Add Method

Adds a component to the selection set.

Syntax

Add(

comp As IAcSmComponent) As Object

comp Input sheet or subset to be added to the selection set


AcSmSheetSelSets.Add

Up a level to AcSmSheetSelSets
AcSmSheetSelSets.Add Method

Adds a new selection set component and adds the component to the sheet set.

The caller must release the interface when the operation is complete.

Syntax

Add(

name As String,

desc As String,

selset As IAcSmSheetSelSet) As Object

name | Input string containing the name of the selection set component to be added
desc | Input string containing the text to set as the description of the selection set component
selset | Output pointer to an IAcSmSheetSelSet interface


AcSmSheetSet.AddNewSheet

Up a level to AcSmSheetSet
AcSmSheetSet.AddNewSheet Method

Constructs a new sheet component. The new sheet is not automatically inserted into the collection.

Syntax

AddNewSheet(

name As String,

desc As String) As IAcSmSheet

name | Input string containing Name value
desc | Input string containing the text to set as the description


AcSmSubset.AddNewSheet

Up a level to AcSmSubset
AcSmSubset.AddNewSheet Method

Adds a new sheet component without adding it to the subset.

To add the new sheet component to the subset, use the InsertComponent method.

Syntax

AddNewSheet(

name As String,

desc As String) As IAcSmSheet

name | Input string containing Name value of the new sheet
desc | Input string containing the text to set as the description


AcSmAcDbBlockRecordReference.Clear

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmAcDbLayoutReference.Clear

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmAcDbObjectReference.Clear

Up a level to AcSmAcDbObjectReference
AcSmAcDbObjectReference.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmAcDbViewReference.Clear

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmCalloutBlockReferences.Clear

Up a level to AcSmCalloutBlockReferences
AcSmCalloutBlockReferences.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmCalloutBlocks.Clear

Up a level to AcSmCalloutBlocks
AcSmCalloutBlocks.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmCustomPropertyBag.Clear

Up a level to AcSmCustomPropertyBag
AcSmCustomPropertyBag.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmCustomPropertyValue.Clear

Up a level to AcSmCustomPropertyValue
AcSmCustomPropertyValue.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmDatabase.Clear

Up a level to AcSmDatabase
AcSmDatabase.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmFileReference.Clear

Up a level to AcSmFileReference
AcSmFileReference.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmNamedAcDbObjectReference.Clear

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmObjectReference.Clear

Up a level to AcSmObjectReference
AcSmObjectReference.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmPersistProxy.Clear

Up a level to AcSmPersistProxy
AcSmPersistProxy.Clear Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Clear() As Object


AcSmPublishOptions.Clear

Up a level to AcSmPublishOptions
AcSmPublishOptions.Clear Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Clear() As Object


AcSmResources.Clear

Up a level to AcSmResources
AcSmResources.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmSheet.Clear

Up a level to AcSmSheet
AcSmSheet.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmSheetSelSet.Clear

Up a level to AcSmSheetSelSet
AcSmSheetSelSet.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmSheetSelSets.Clear

Up a level to AcSmSheetSelSets
AcSmSheetSelSets.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmSheetSet.Clear

Up a level to AcSmSheetSet
AcSmSheetSet.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmSheetView.Clear

Up a level to AcSmSheetView
AcSmSheetView.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmSheetViews.Clear

Up a level to AcSmSheetViews
AcSmSheetViews.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmSubset.Clear

Up a level to AcSmSubset
AcSmSubset.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmViewCategories.Clear

Up a level to AcSmViewCategories
AcSmViewCategories.Clear Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Clear() As Object


AcSmViewCategory.Clear

Up a level to AcSmViewCategory
AcSmViewCategory.Clear Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Clear() As Object


IAcSmComponent.Clear

Up a level to IAcSmComponent
IAcSmComponent.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


IAcSmPersist.Clear

Up a level to IAcSmPersist
IAcSmPersist.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

Clear() As Object


AcSmDSTFiler.Close

Up a level to AcSmDSTFiler
AcSmDSTFiler.Close Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Close(

bSuccess As Boolean) As Object

bSuccess Input Boolean


AcSmSheetSetMgr.Close

Up a level to AcSmSheetSetMgr
AcSmSheetSetMgr.Close Method

Closes a database.

Syntax

Close(

db As IAcSmDatabase) As Object

db Input IAcSmDatabase to close


AcSmSheetSetMgr.CloseAll

Up a level to AcSmSheetSetMgr
AcSmSheetSetMgr.CloseAll Method

Closes all open databases.

Syntax

CloseAll() As Object


AcSmSheetSetMgr.CreateDatabase

Up a level to AcSmSheetSetMgr
AcSmSheetSetMgr.CreateDatabase Method

Creates a new database (DST file) and returns the IAcSmDatabase component for the database.

The method fails if the database file exists. If the templatefileName parameter is null or is an empty ("") string, then a database file is created without a template. If the templatefileName parameter specifies a file that is not found or read, E_FAIL is returned.

The caller must release the interface when the operation is complete.

Syntax

CreateDatabase(

filename As String,

templatefilename As String = 0,

bAlwaysCreate As Boolean = True) As IAcSmDatabase

filename | Input file name of the database to be created
templatefilename | Input file name of the template for the database
bAlwaysCreate | Input Boolean indicating whether to create a new DST file even when there is an existing DST file with the same name


AcSmSheetSet.CreateSubset

Up a level to AcSmSheetSet
AcSmSheetSet.CreateSubset Method

Constructs a new subset component. The new subset is not inserted automatically into the collection.

Syntax

CreateSubset(

name As String,

desc As String) As IAcSmSubset

name | Input string containing Name value
desc | Input string containing the text to set as the description


AcSmSubset.CreateSubset

Up a level to AcSmSubset
AcSmSubset.CreateSubset Method

Adds a new subset component without adding it to the current subset.

The caller must release the interface when the operation is complete.

Syntax

CreateSubset(

name As String,

desc As String) As IAcSmSubset

name | Input string containing the Name value of the new subset component
desc | Input string containing the text to set as the description of the new subset


AcSmViewCategories.CreateViewCategory

Up a level to AcSmViewCategories
AcSmViewCategories.CreateViewCategory Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

CreateViewCategory(

name As String,

desc As String,

id As String) As IAcSmViewCategory

name | Input string containing Name value
desc | Input string containing the text to set as the description
id | Input ID


AcSmDatabase.FindObject

Up a level to AcSmDatabase
AcSmDatabase.FindObject Method

Finds an IAcSmPersist object based on the persisted handle of the object instance.

The caller must release the interface when the operation is complete.

Syntax

FindObject(

hand As String) As IAcSmPersist

hand Input object handle, or null if a new ID is requested


AcSmSheetSetMgr.FindOpenDatabase

Up a level to AcSmSheetSetMgr
AcSmSheetSetMgr.FindOpenDatabase Method

Checks the open databases for a specific database.

The caller must release the interface when the operation is complete.

Syntax

FindOpenDatabase(

filename As String) As IAcSmDatabase

filename Input file name of the open database to find


AcSmAcDbDatabase.GetAcDbDatabase

Up a level to AcSmAcDbDatabase
AcSmAcDbDatabase.GetAcDbDatabase Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetAcDbDatabase() As Object


AcSmAcDbBlockRecordReference.GetAcDbHandle

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.GetAcDbHandle Method

Retrieves the AcDbHandle of the referenced AcDbObject. The name of the referenced object may not be the current name of the object.

Syntax

GetAcDbHandle() As String


AcSmAcDbLayoutReference.GetAcDbHandle

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.GetAcDbHandle Method

Retrieves the AcDbHandle of the referenced AcDbObject. The name of the referenced object may not be the current name of the object.

Syntax

GetAcDbHandle() As String


AcSmAcDbObjectReference.GetAcDbHandle

Up a level to AcSmAcDbObjectReference
AcSmAcDbObjectReference.GetAcDbHandle Method

Retrieves the AcDbHandle of the referenced AcDbObject. The name of the referenced object may not be the current name of the object.

Syntax

GetAcDbHandle() As String


AcSmAcDbViewReference.GetAcDbHandle

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.GetAcDbHandle Method

Retrieves the AcDbHandle of the referenced AcDbObject. The name of the referenced object may not be the current name of the object.

Syntax

GetAcDbHandle() As String


AcSmNamedAcDbObjectReference.GetAcDbHandle

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.GetAcDbHandle Method

Retrieves the AcDbHandle of the referenced AcDbObject. The name of the referenced object may not be the current name of the object.

Syntax

GetAcDbHandle() As String


AcSmAcDbBlockRecordReference.GetAcSmAcDbDatabase

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.GetAcSmAcDbDatabase Method

Returns the open AcSmAcDbDatabase containing the referenced AcDbObject.

Syntax

GetAcSmAcDbDatabase() As AcSmAcDbDatabase


AcSmAcDbLayoutReference.GetAcSmAcDbDatabase

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.GetAcSmAcDbDatabase Method

Returns the open AcSmAcDbDatabase containing the referenced AcDbObject.

Syntax

GetAcSmAcDbDatabase() As AcSmAcDbDatabase


AcSmAcDbObjectReference.GetAcSmAcDbDatabase

Up a level to AcSmAcDbObjectReference
AcSmAcDbObjectReference.GetAcSmAcDbDatabase Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetAcSmAcDbDatabase() As AcSmAcDbDatabase


AcSmAcDbViewReference.GetAcSmAcDbDatabase

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.GetAcSmAcDbDatabase Method

Returns the open AcSmAcDbDatabase containing the referenced AcDbObject.

Syntax

GetAcSmAcDbDatabase() As AcSmAcDbDatabase


AcSmNamedAcDbObjectReference.GetAcSmAcDbDatabase

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.GetAcSmAcDbDatabase Method

Returns the open AcSmAcDbDatabase containing the referenced AcDbObject.

Syntax

GetAcSmAcDbDatabase() As AcSmAcDbDatabase


AcSmSheetSet.GetAltPageSetups

Up a level to AcSmSheetSet
AcSmSheetSet.GetAltPageSetups Method

Retrieves the IAcSmFileReference component that references the template containing alternative page setups.

The caller must release the allocated memory when the operation is complete.

Syntax

GetAltPageSetups() As IAcSmFileReference


AcSmSheetSet.GetCalloutBlocks

Up a level to AcSmSheetSet
AcSmSheetSet.GetCalloutBlocks Method

Returns a collection of callout block references that are associated with the sheet set.

The caller must release the interface when the operation is complete.

Syntax

GetCalloutBlocks() As IAcSmCalloutBlocks


AcSmViewCategory.GetCalloutBlocks

Up a level to AcSmViewCategory
AcSmViewCategory.GetCalloutBlocks Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetCalloutBlocks() As IAcSmCalloutBlocks


AcSmSheet.GetCategory

Up a level to AcSmSheet
AcSmSheet.GetCategory Method

Retrieves the Category property. Returns S_OK if successful.

Syntax

GetCategory(

pVal As BSTR*) As HRESULT

pVal Output pointer to a string containing the value of the Category property


AcSmSheetView.GetCategory

Up a level to AcSmSheetView
AcSmSheetView.GetCategory Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetCategory() As IAcSmViewCategory


AcSmDSTFiler.GetCurrentObject

Up a level to AcSmDSTFiler
AcSmDSTFiler.GetCurrentObject Method

This API was designed for internal use and has not been thoroughly tested.

The caller must release the IAcSmPersist object when the operation is completed.

Syntax

GetCurrentObject() As IAcSmPersist


AcSmDSTFiler.GetCurrentObjectHeaderInfo

Up a level to AcSmDSTFiler
AcSmDSTFiler.GetCurrentObjectHeaderInfo Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetCurrentObjectHeaderInfo(

names As String(),

values As String()) As Object

names | Output pointer to a SAFEARRAY of strings containing the names of the header entries of the object
values | Output pointer to a SAFEARRAY of strings containing the values of the header entries of the object


AcSmCalloutBlockReferences.GetCustomPropertyBag

Up a level to AcSmCalloutBlockReferences
AcSmCalloutBlockReferences.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmCalloutBlocks.GetCustomPropertyBag

Up a level to AcSmCalloutBlocks
AcSmCalloutBlocks.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmDatabase.GetCustomPropertyBag

Up a level to AcSmDatabase
AcSmDatabase.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmResources.GetCustomPropertyBag

Up a level to AcSmResources
AcSmResources.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmSheet.GetCustomPropertyBag

Up a level to AcSmSheet
AcSmSheet.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmSheetSelSet.GetCustomPropertyBag

Up a level to AcSmSheetSelSet
AcSmSheetSelSet.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmSheetSelSets.GetCustomPropertyBag

Up a level to AcSmSheetSelSets
AcSmSheetSelSets.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmSheetSet.GetCustomPropertyBag

Up a level to AcSmSheetSet
AcSmSheetSet.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmSheetView.GetCustomPropertyBag

Up a level to AcSmSheetView
AcSmSheetView.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmSheetViews.GetCustomPropertyBag

Up a level to AcSmSheetViews
AcSmSheetViews.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmSubset.GetCustomPropertyBag

Up a level to AcSmSubset
AcSmSubset.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmViewCategories.GetCustomPropertyBag

Up a level to AcSmViewCategories
AcSmViewCategories.GetCustomPropertyBag Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmViewCategory.GetCustomPropertyBag

Up a level to AcSmViewCategory
AcSmViewCategory.GetCustomPropertyBag Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


IAcSmComponent.GetCustomPropertyBag

Up a level to IAcSmComponent
IAcSmComponent.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

The caller must release the IAcSmPropertyBag object when the operation is completed.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmAcDbBlockRecordReference.GetDatabase

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmAcDbLayoutReference.GetDatabase

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmAcDbObjectReference.GetDatabase

Up a level to AcSmAcDbObjectReference
AcSmAcDbObjectReference.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmAcDbViewReference.GetDatabase

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmCalloutBlockReferences.GetDatabase

Up a level to AcSmCalloutBlockReferences
AcSmCalloutBlockReferences.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmCalloutBlocks.GetDatabase

Up a level to AcSmCalloutBlocks
AcSmCalloutBlocks.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmCustomPropertyBag.GetDatabase

Up a level to AcSmCustomPropertyBag
AcSmCustomPropertyBag.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmCustomPropertyValue.GetDatabase

Up a level to AcSmCustomPropertyValue
AcSmCustomPropertyValue.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmDatabase.GetDatabase

Up a level to AcSmDatabase
AcSmDatabase.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmDSTFiler.GetDatabase

Up a level to AcSmDSTFiler
AcSmDSTFiler.GetDatabase Method

This API was designed for internal use and has not been thoroughly tested.

The caller must release the IAcSmDatabase object when the operation is completed.

Syntax

GetDatabase() As IAcSmDatabase


AcSmFileReference.GetDatabase

Up a level to AcSmFileReference
AcSmFileReference.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmNamedAcDbObjectReference.GetDatabase

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmObjectReference.GetDatabase

Up a level to AcSmObjectReference
AcSmObjectReference.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmPersistProxy.GetDatabase

Up a level to AcSmPersistProxy
AcSmPersistProxy.GetDatabase Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDatabase() As IAcSmDatabase


AcSmPublishOptions.GetDatabase

Up a level to AcSmPublishOptions
AcSmPublishOptions.GetDatabase Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDatabase() As IAcSmDatabase


AcSmResources.GetDatabase

Up a level to AcSmResources
AcSmResources.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmSheet.GetDatabase

Up a level to AcSmSheet
AcSmSheet.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmSheetSelSet.GetDatabase

Up a level to AcSmSheetSelSet
AcSmSheetSelSet.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmSheetSelSets.GetDatabase

Up a level to AcSmSheetSelSets
AcSmSheetSelSets.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmSheetSet.GetDatabase

Up a level to AcSmSheetSet
AcSmSheetSet.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmSheetView.GetDatabase

Up a level to AcSmSheetView
AcSmSheetView.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmSheetViews.GetDatabase

Up a level to AcSmSheetViews
AcSmSheetViews.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmSubset.GetDatabase

Up a level to AcSmSubset
AcSmSubset.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmViewCategories.GetDatabase

Up a level to AcSmViewCategories
AcSmViewCategories.GetDatabase Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDatabase() As IAcSmDatabase


AcSmViewCategory.GetDatabase

Up a level to AcSmViewCategory
AcSmViewCategory.GetDatabase Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDatabase() As IAcSmDatabase


IAcSmComponent.GetDatabase

Up a level to IAcSmComponent
IAcSmComponent.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


IAcSmObjectId.GetDatabase

Up a level to IAcSmObjectId
IAcSmObjectId.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the interface when the operation is complete.

Syntax

GetDatabase() As IAcSmDatabase


IAcSmPersist.GetDatabase

Up a level to IAcSmPersist
IAcSmPersist.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmDatabase object when the operation is completed.

Syntax

GetDatabase() As IAcSmDatabase


AcSmSheetSetMgr.GetDatabaseEnumerator

Up a level to AcSmSheetSetMgr
AcSmSheetSetMgr.GetDatabaseEnumerator Method

Returns an enumerator of the currently open IAcSmDatabase components handled by the manager.

The caller must release the interface when the operation is complete.

Syntax

GetDatabaseEnumerator() As IAcSmEnumDatabase


AcSmDatabase.GetDbVersion

Up a level to AcSmDatabase
AcSmDatabase.GetDbVersion Method

Gets the version number of an AcSmDatabase.

Syntax

GetDbVersion() As String


AcSmSheetSet.GetDefAltPageSetup

Up a level to AcSmSheetSet
AcSmSheetSet.GetDefAltPageSetup Method

Retrieves the IAcSmNamedAcDbObjectReference component that references the default page setup within the template containing alternative page setups.

Syntax

GetDefAltPageSetup() As IAcSmNamedAcDbObjectReference


AcSmPublishOptions.GetDefaultOutputdir

Up a level to AcSmPublishOptions
AcSmPublishOptions.GetDefaultOutputdir Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDefaultOutputdir() As String


AcSmViewCategories.GetDefaultViewCategory

Up a level to AcSmViewCategories
AcSmViewCategories.GetDefaultViewCategory Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDefaultViewCategory() As IAcSmViewCategory


AcSmSheetSet.GetDefDwtLayout

Up a level to AcSmSheetSet
AcSmSheetSet.GetDefDwtLayout Method

Returns the IAcSmNamedAcDbObjectReference that points to the AcDbLayout to be used as a template for new sheet creation.

Syntax

GetDefDwtLayout() As IAcSmNamedAcDbObjectReference


AcSmSubset.GetDefDwtLayout

Up a level to AcSmSubset
AcSmSubset.GetDefDwtLayout Method

Returns the IAcSmNamedAcDbObjectReference that points to the layout used as a template for new sheets.

The caller must release the interface when operations are complete.

Syntax

GetDefDwtLayout() As IAcSmNamedAcDbObjectReference


AcSmSheetSet.GetDefLabelBlk

Up a level to AcSmSheetSet
AcSmSheetSet.GetDefLabelBlk Method

Returns the IAcSmNamedAcDbObjectReference component that references the label block definition for the sheet set.

The caller must release the interface when the operation is complete.

Syntax

GetDefLabelBlk() As IAcSmNamedAcDbObjectReference


AcSmCalloutBlockReferences.GetDesc

Up a level to AcSmCalloutBlockReferences
AcSmCalloutBlockReferences.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmCalloutBlocks.GetDesc

Up a level to AcSmCalloutBlocks
AcSmCalloutBlocks.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmDatabase.GetDesc

Up a level to AcSmDatabase
AcSmDatabase.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmResources.GetDesc

Up a level to AcSmResources
AcSmResources.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmSheet.GetDesc

Up a level to AcSmSheet
AcSmSheet.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmSheetSelSet.GetDesc

Up a level to AcSmSheetSelSet
AcSmSheetSelSet.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmSheetSelSets.GetDesc

Up a level to AcSmSheetSelSets
AcSmSheetSelSets.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmSheetSet.GetDesc

Up a level to AcSmSheetSet
AcSmSheetSet.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmSheetView.GetDesc

Up a level to AcSmSheetView
AcSmSheetView.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmSheetViews.GetDesc

Up a level to AcSmSheetViews
AcSmSheetViews.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmSubset.GetDesc

Up a level to AcSmSubset
AcSmSubset.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmViewCategories.GetDesc

Up a level to AcSmViewCategories
AcSmViewCategories.GetDesc Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDesc() As String


AcSmViewCategory.GetDesc

Up a level to AcSmViewCategory
AcSmViewCategory.GetDesc Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDesc() As String


IAcSmComponent.GetDesc

Up a level to IAcSmComponent
IAcSmComponent.GetDesc Method

Retrieves the description of the component.

The caller must release the allocated memory when the operation is complete.

Syntax

GetDesc() As String


AcSmAcDbBlockRecordReference.GetDirectlyOwnedObjects

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmAcDbLayoutReference.GetDirectlyOwnedObjects

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmAcDbObjectReference.GetDirectlyOwnedObjects

Up a level to AcSmAcDbObjectReference
AcSmAcDbObjectReference.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmAcDbViewReference.GetDirectlyOwnedObjects

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmCalloutBlockReferences.GetDirectlyOwnedObjects

Up a level to AcSmCalloutBlockReferences
AcSmCalloutBlockReferences.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmCalloutBlocks.GetDirectlyOwnedObjects

Up a level to AcSmCalloutBlocks
AcSmCalloutBlocks.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmCustomPropertyBag.GetDirectlyOwnedObjects

Up a level to AcSmCustomPropertyBag
AcSmCustomPropertyBag.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmCustomPropertyValue.GetDirectlyOwnedObjects

Up a level to AcSmCustomPropertyValue
AcSmCustomPropertyValue.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmDatabase.GetDirectlyOwnedObjects

Up a level to AcSmDatabase
AcSmDatabase.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmFileReference.GetDirectlyOwnedObjects

Up a level to AcSmFileReference
AcSmFileReference.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmNamedAcDbObjectReference.GetDirectlyOwnedObjects

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmObjectReference.GetDirectlyOwnedObjects

Up a level to AcSmObjectReference
AcSmObjectReference.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmPersistProxy.GetDirectlyOwnedObjects

Up a level to AcSmPersistProxy
AcSmPersistProxy.GetDirectlyOwnedObjects Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmPublishOptions.GetDirectlyOwnedObjects

Up a level to AcSmPublishOptions
AcSmPublishOptions.GetDirectlyOwnedObjects Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDirectlyOwnedObjects(

objects As Unknown) As Object

objects Output array of directly owned objects


AcSmResources.GetDirectlyOwnedObjects

Up a level to AcSmResources
AcSmResources.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmSheet.GetDirectlyOwnedObjects

Up a level to AcSmSheet
AcSmSheet.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmSheetSelSet.GetDirectlyOwnedObjects

Up a level to AcSmSheetSelSet
AcSmSheetSelSet.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmSheetSelSets.GetDirectlyOwnedObjects

Up a level to AcSmSheetSelSets
AcSmSheetSelSets.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmSheetSet.GetDirectlyOwnedObjects

Up a level to AcSmSheetSet
AcSmSheetSet.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmSheetView.GetDirectlyOwnedObjects

Up a level to AcSmSheetView
AcSmSheetView.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmSheetViews.GetDirectlyOwnedObjects

Up a level to AcSmSheetViews
AcSmSheetViews.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmSubset.GetDirectlyOwnedObjects

Up a level to AcSmSubset
AcSmSubset.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmViewCategories.GetDirectlyOwnedObjects

Up a level to AcSmViewCategories
AcSmViewCategories.GetDirectlyOwnedObjects Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmViewCategory.GetDirectlyOwnedObjects

Up a level to AcSmViewCategory
AcSmViewCategory.GetDirectlyOwnedObjects Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


IAcSmComponent.GetDirectlyOwnedObjects

Up a level to IAcSmComponent
IAcSmComponent.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


IAcSmPersist.GetDirectlyOwnedObjects

Up a level to IAcSmPersist
IAcSmPersist.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(

objects As Object()) As Object

objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmSheet.GetDoNotPlot

Up a level to AcSmSheet
AcSmSheet.GetDoNotPlot Method

Retreives a flag indicating whether a sheet should be skipped during plotting and publishing.

Syntax

GetDoNotPlot() As Boolean


AcSmPublishOptions.GetDwfType

Up a level to AcSmPublishOptions
AcSmPublishOptions.GetDwfType Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDwfType() As Boolean


AcSmCalloutBlockReferences.GetEnumerator

Up a level to AcSmCalloutBlockReferences
AcSmCalloutBlockReferences.GetEnumerator Method

Returns an enumerator of the contained IAcSmNamedAcDbObjectReference components in the collection.

Syntax

GetEnumerator() As IAcSmEnumNamedAcDbObjectReference


AcSmCalloutBlocks.GetEnumerator

Up a level to AcSmCalloutBlocks
AcSmCalloutBlocks.GetEnumerator Method

Returns an enumerator of the contained IAcSmNamedAcDbObjectReference components in the collection.

The caller must release the interface when the operation is complete.

Syntax

GetEnumerator() As IAcSmEnumNamedAcDbObjectReference


AcSmDatabase.GetEnumerator

Up a level to AcSmDatabase
AcSmDatabase.GetEnumerator Method

Returns an enumerator of all objects in the database.

The caller must release the interface when the operation is complete.

Syntax

GetEnumerator() As IAcSmEnumPersist


AcSmResources.GetEnumerator

Up a level to AcSmResources
AcSmResources.GetEnumerator Method

Returns an enumerator of the contained IAcSmFileReference components in the collection.

The caller must release the interface when the operation is complete.

Syntax

GetEnumerator() As IAcSmEnumFileReference


AcSmSheetSelSet.GetEnumerator

Up a level to AcSmSheetSelSet
AcSmSheetSelSet.GetEnumerator Method

Returns an enumerator of the components in the selection set.

The caller must release the interface when the operation is complete.

Syntax

GetEnumerator() As IAcSmEnumComponent


AcSmSheetSelSets.GetEnumerator

Up a level to AcSmSheetSelSets
AcSmSheetSelSets.GetEnumerator Method

Returns an enumerator of the selection sets in the collection.

The caller must release the interface when the operation is complete.

Syntax

GetEnumerator() As IAcSmEnumSheetSelSet


AcSmSheetViews.GetEnumerator

Up a level to AcSmSheetViews
AcSmSheetViews.GetEnumerator Method

Returns an enumerator of the contained sheet views in the collection.

The caller must release the interface when the operation is complete.

Syntax

GetEnumerator() As IAcSmEnumSheetView


AcSmViewCategories.GetEnumerator

Up a level to AcSmViewCategories
AcSmViewCategories.GetEnumerator Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetEnumerator() As IAcSmEnumViewCategory


AcSmAcDbBlockRecordReference.GetFileName

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.GetFileName Method

Retrieves the file name property of this file reference.

Syntax

GetFileName() As String


AcSmAcDbLayoutReference.GetFileName

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.GetFileName Method

Retrieves the file name property of this file reference.

Syntax

GetFileName() As String


AcSmAcDbObjectReference.GetFileName

Up a level to AcSmAcDbObjectReference
AcSmAcDbObjectReference.GetFileName Method

Retrieves the file name property of this file reference.

Syntax

GetFileName() As String


AcSmAcDbViewReference.GetFileName

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.GetFileName Method

Retrieves the file name property of this file reference.

Syntax

GetFileName() As String


AcSmDatabase.GetFileName

Up a level to AcSmDatabase
AcSmDatabase.GetFileName Method

Retrieves the file name of the database.

Syntax

GetFileName() As String


AcSmFileReference.GetFileName

Up a level to AcSmFileReference
AcSmFileReference.GetFileName Method

Retrieves the file name that this object references.

Syntax

GetFileName() As String


AcSmNamedAcDbObjectReference.GetFileName

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.GetFileName Method

Retrieves the file name property of this file reference.

Syntax

GetFileName() As String


AcSmCustomPropertyValue.GetFlags

Up a level to AcSmCustomPropertyValue
AcSmCustomPropertyValue.GetFlags Method

Retrieves a combination of PropertyFlags enum values associated with the custom property.

Syntax

GetFlags() As __MIDL___MIDL_itf_AcSmComponents_0264_0001


IAcSmObjectId.GetHandle

Up a level to IAcSmObjectId
IAcSmObjectId.GetHandle Method

Retrieves the persisted, unique handle.

Syntax

GetHandle() As String


AcSmAcDbDatabase.GetIAcadDatabase

Up a level to AcSmAcDbDatabase
AcSmAcDbDatabase.GetIAcadDatabase Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetIAcadDatabase() As AcadDatabase


AcSmPublishOptions.GetIncludePlotStamp

Up a level to AcSmPublishOptions
AcSmPublishOptions.GetIncludePlotStamp Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetIncludePlotStamp() As Boolean


AcSmAcDbBlockRecordReference.GetIsDirty

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmAcDbLayoutReference.GetIsDirty

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmAcDbObjectReference.GetIsDirty

Up a level to AcSmAcDbObjectReference
AcSmAcDbObjectReference.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmAcDbViewReference.GetIsDirty

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmCalloutBlockReferences.GetIsDirty

Up a level to AcSmCalloutBlockReferences
AcSmCalloutBlockReferences.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmCalloutBlocks.GetIsDirty

Up a level to AcSmCalloutBlocks
AcSmCalloutBlocks.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmCustomPropertyBag.GetIsDirty

Up a level to AcSmCustomPropertyBag
AcSmCustomPropertyBag.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmCustomPropertyValue.GetIsDirty

Up a level to AcSmCustomPropertyValue
AcSmCustomPropertyValue.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmDatabase.GetIsDirty

Up a level to AcSmDatabase
AcSmDatabase.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmFileReference.GetIsDirty

Up a level to AcSmFileReference
AcSmFileReference.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmNamedAcDbObjectReference.GetIsDirty

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmObjectReference.GetIsDirty

Up a level to AcSmObjectReference
AcSmObjectReference.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmPersistProxy.GetIsDirty

Up a level to AcSmPersistProxy
AcSmPersistProxy.GetIsDirty Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetIsDirty() As Boolean


AcSmPublishOptions.GetIsDirty

Up a level to AcSmPublishOptions
AcSmPublishOptions.GetIsDirty Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetIsDirty() As Boolean


AcSmResources.GetIsDirty

Up a level to AcSmResources
AcSmResources.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmSheet.GetIsDirty

Up a level to AcSmSheet
AcSmSheet.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmSheetSelSet.GetIsDirty

Up a level to AcSmSheetSelSet
AcSmSheetSelSet.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmSheetSelSets.GetIsDirty

Up a level to AcSmSheetSelSets
AcSmSheetSelSets.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmSheetSet.GetIsDirty

Up a level to AcSmSheetSet
AcSmSheetSet.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmSheetView.GetIsDirty

Up a level to AcSmSheetView
AcSmSheetView.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmSheetViews.GetIsDirty

Up a level to AcSmSheetViews
AcSmSheetViews.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmSubset.GetIsDirty

Up a level to AcSmSubset
AcSmSubset.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmViewCategories.GetIsDirty

Up a level to AcSmViewCategories
AcSmViewCategories.GetIsDirty Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetIsDirty() As Boolean


AcSmViewCategory.GetIsDirty

Up a level to AcSmViewCategory
AcSmViewCategory.GetIsDirty Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetIsDirty() As Boolean


IAcSmComponent.GetIsDirty

Up a level to IAcSmComponent
IAcSmComponent.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


IAcSmPersist.GetIsDirty

Up a level to IAcSmPersist
IAcSmPersist.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmSheet.GetIssuePurpose

Up a level to AcSmSheet
AcSmSheet.GetIssuePurpose Method

Retrieves the IssuePurpose property. Returns S_OK if successful.

Syntax

GetIssuePurpose(

pVal As BSTR*) As HRESULT

pVal Output pointer to a string containing the value of the IssuePurpose property


AcSmDatabase.GetIsTemporary

Up a level to AcSmDatabase
AcSmDatabase.GetIsTemporary Method

Retrieves a flag indicating a non-persisted database.

Syntax

GetIsTemporary() As Boolean


AcSmPublishOptions.GetLayerInfo

Up a level to AcSmPublishOptions
AcSmPublishOptions.GetLayerInfo Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetLayerInfo() As Boolean


AcSmSheet.GetLayout

Up a level to AcSmSheet
AcSmSheet.GetLayout Method

Returns the IAcSmNamedAcDbObjectReference object, which references the drawing and layout associated with the sheet component.

The caller must release the interface when the operation is completed.

Syntax

GetLayout() As IAcSmNamedAcDbObjectReference


AcSmDatabase.GetLockOwnerInfo

Up a level to AcSmDatabase
AcSmDatabase.GetLockOwnerInfo Method

Returns the user name and machine name of the lock owner.

Syntax

GetLockOwnerInfo(

pstrUserName As String,

pstrMachineName As String) As Object

pstrUserName | Output user name of the user who locked the database
pstrMachineName | Output machine name of the user who locked the database


AcSmDatabase.GetLockStatus

Up a level to AcSmDatabase
AcSmDatabase.GetLockStatus Method

Retrieves the lock status of the database.

Syntax

GetLockStatus() As AcSmLockStatus


AcSmAcDbBlockRecordReference.GetName

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.GetName Method

Retrieves the name of the referenced object. The name of the referenced object might not be the current name of the object.

Syntax

GetName() As String


AcSmAcDbLayoutReference.GetName

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.GetName Method

Retrieves the name of the referenced object. The name of the referenced object might not be the current name of the object.

Syntax

GetName() As String


AcSmAcDbViewReference.GetName

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.GetName Method

Retrieves the name of the referenced object. The name of the referenced object might not be the current name of the object.

Syntax

GetName() As String


AcSmCalloutBlockReferences.GetName

Up a level to AcSmCalloutBlockReferences
AcSmCalloutBlockReferences.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmCalloutBlocks.GetName

Up a level to AcSmCalloutBlocks
AcSmCalloutBlocks.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmDatabase.GetName

Up a level to AcSmDatabase
AcSmDatabase.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmNamedAcDbObjectReference.GetName

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.GetName Method

Retrieves the name of the referenced object. The name of the referenced object might not be the current name of the object.

Syntax

GetName() As String


AcSmResources.GetName

Up a level to AcSmResources
AcSmResources.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmSheet.GetName

Up a level to AcSmSheet
AcSmSheet.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmSheetSelSet.GetName

Up a level to AcSmSheetSelSet
AcSmSheetSelSet.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmSheetSelSets.GetName

Up a level to AcSmSheetSelSets
AcSmSheetSelSets.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmSheetSet.GetName

Up a level to AcSmSheetSet
AcSmSheetSet.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmSheetView.GetName

Up a level to AcSmSheetView
AcSmSheetView.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmSheetViews.GetName

Up a level to AcSmSheetViews
AcSmSheetViews.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmSubset.GetName

Up a level to AcSmSubset
AcSmSubset.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmViewCategories.GetName

Up a level to AcSmViewCategories
AcSmViewCategories.GetName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetName() As String


AcSmViewCategory.GetName

Up a level to AcSmViewCategory
AcSmViewCategory.GetName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetName() As String


IAcSmComponent.GetName

Up a level to IAcSmComponent
IAcSmComponent.GetName Method

Retrieves the Name property of the component.

The caller must release the allocated memory when the operation is complete.

Syntax

GetName() As String


AcSmSheetView.GetNamedView

Up a level to AcSmSheetView
AcSmSheetView.GetNamedView Method

Returns an IAcSmNamedAcDbObjectReference that points to the named AcDbView object on the sheet referenced by the sheet view component.

The caller must release the returned interface when the operation is complete.

Syntax

GetNamedView() As IAcSmNamedAcDbObjectReference


AcSmDatabase.GetNewObjectId

Up a level to AcSmDatabase
AcSmDatabase.GetNewObjectId Method

Retrieves the IAcSmObjectId for a handle or generates a new ID.

The caller must release the interface when the operation is complete.

Syntax

GetNewObjectId(

hand As String,

idcookie As Long) As IAcSmObjectId

hand | Input object handle, or null if a new ID is requested
idcookie | Output returned cookie from the database to use as a security key for changing ownership and for other access to the object ID properties


AcSmSheetSet.GetNewSheetLocation

Up a level to AcSmSheetSet
AcSmSheetSet.GetNewSheetLocation Method

Returns the IAcSmFileReference that points to the file system location where new sheets will be created.

Syntax

GetNewSheetLocation() As IAcSmFileReference


AcSmSubset.GetNewSheetLocation

Up a level to AcSmSubset
AcSmSubset.GetNewSheetLocation Method

Returns the IAcSmFileReference that points to the location in the file system where new sheets are created.

The caller must release the interface when operations are complete.

Syntax

GetNewSheetLocation() As IAcSmFileReference


AcSmSheet.GetNumber

Up a level to AcSmSheet
AcSmSheet.GetNumber Method

Retrieves the Number property of the sheet.

Syntax

GetNumber() As String


AcSmSheetView.GetNumber

Up a level to AcSmSheetView
AcSmSheetView.GetNumber Method

Retrieves the Number property of the sheet view.

Syntax

GetNumber() As String


AcSmAcDbBlockRecordReference.GetObjectId

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmAcDbLayoutReference.GetObjectId

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmAcDbObjectReference.GetObjectId

Up a level to AcSmAcDbObjectReference
AcSmAcDbObjectReference.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmAcDbViewReference.GetObjectId

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmCalloutBlockReferences.GetObjectId

Up a level to AcSmCalloutBlockReferences
AcSmCalloutBlockReferences.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmCalloutBlocks.GetObjectId

Up a level to AcSmCalloutBlocks
AcSmCalloutBlocks.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmCustomPropertyBag.GetObjectId

Up a level to AcSmCustomPropertyBag
AcSmCustomPropertyBag.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmCustomPropertyValue.GetObjectId

Up a level to AcSmCustomPropertyValue
AcSmCustomPropertyValue.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmDatabase.GetObjectId

Up a level to AcSmDatabase
AcSmDatabase.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmFileReference.GetObjectId

Up a level to AcSmFileReference
AcSmFileReference.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmNamedAcDbObjectReference.GetObjectId

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmObjectReference.GetObjectId

Up a level to AcSmObjectReference
AcSmObjectReference.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmPersistProxy.GetObjectId

Up a level to AcSmPersistProxy
AcSmPersistProxy.GetObjectId Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetObjectId() As IAcSmObjectId


AcSmPublishOptions.GetObjectId

Up a level to AcSmPublishOptions
AcSmPublishOptions.GetObjectId Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetObjectId() As IAcSmObjectId


AcSmResources.GetObjectId

Up a level to AcSmResources
AcSmResources.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmSheet.GetObjectId

Up a level to AcSmSheet
AcSmSheet.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmSheetSelSet.GetObjectId

Up a level to AcSmSheetSelSet
AcSmSheetSelSet.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmSheetSelSets.GetObjectId

Up a level to AcSmSheetSelSets
AcSmSheetSelSets.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmSheetSet.GetObjectId

Up a level to AcSmSheetSet
AcSmSheetSet.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmSheetView.GetObjectId

Up a level to AcSmSheetView
AcSmSheetView.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmSheetViews.GetObjectId

Up a level to AcSmSheetViews
AcSmSheetViews.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmSubset.GetObjectId

Up a level to AcSmSubset
AcSmSubset.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmViewCategories.GetObjectId

Up a level to AcSmViewCategories
AcSmViewCategories.GetObjectId Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetObjectId() As IAcSmObjectId


AcSmViewCategory.GetObjectId

Up a level to AcSmViewCategory
AcSmViewCategory.GetObjectId Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetObjectId() As IAcSmObjectId


IAcSmComponent.GetObjectId

Up a level to IAcSmComponent
IAcSmComponent.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


IAcSmPersist.GetObjectId

Up a level to IAcSmPersist
IAcSmPersist.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmPublishOptions.GetOutputFileName

Up a level to AcSmPublishOptions
AcSmPublishOptions.GetOutputFileName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetOutputFileName() As IAcSmFileReference


AcSmAcDbBlockRecordReference.GetOwner

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmAcDbLayoutReference.GetOwner

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmAcDbObjectReference.GetOwner

Up a level to AcSmAcDbObjectReference
AcSmAcDbObjectReference.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmAcDbViewReference.GetOwner

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmCalloutBlockReferences.GetOwner

Up a level to AcSmCalloutBlockReferences
AcSmCalloutBlockReferences.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmCalloutBlocks.GetOwner

Up a level to AcSmCalloutBlocks
AcSmCalloutBlocks.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmCustomPropertyBag.GetOwner

Up a level to AcSmCustomPropertyBag
AcSmCustomPropertyBag.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmCustomPropertyValue.GetOwner

Up a level to AcSmCustomPropertyValue
AcSmCustomPropertyValue.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmDatabase.GetOwner

Up a level to AcSmDatabase
AcSmDatabase.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmFileReference.GetOwner

Up a level to AcSmFileReference
AcSmFileReference.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmNamedAcDbObjectReference.GetOwner

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmObjectReference.GetOwner

Up a level to AcSmObjectReference
AcSmObjectReference.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmPersistProxy.GetOwner

Up a level to AcSmPersistProxy
AcSmPersistProxy.GetOwner Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetOwner() As IAcSmPersist


AcSmPublishOptions.GetOwner

Up a level to AcSmPublishOptions
AcSmPublishOptions.GetOwner Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetOwner() As IAcSmPersist


AcSmResources.GetOwner

Up a level to AcSmResources
AcSmResources.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmSheet.GetOwner

Up a level to AcSmSheet
AcSmSheet.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmSheetSelSet.GetOwner

Up a level to AcSmSheetSelSet
AcSmSheetSelSet.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmSheetSelSets.GetOwner

Up a level to AcSmSheetSelSets
AcSmSheetSelSets.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmSheetSet.GetOwner

Up a level to AcSmSheetSet
AcSmSheetSet.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmSheetView.GetOwner

Up a level to AcSmSheetView
AcSmSheetView.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmSheetViews.GetOwner

Up a level to AcSmSheetViews
AcSmSheetViews.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmSubset.GetOwner

Up a level to AcSmSubset
AcSmSubset.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmViewCategories.GetOwner

Up a level to AcSmViewCategories
AcSmViewCategories.GetOwner Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetOwner() As IAcSmPersist


AcSmViewCategory.GetOwner

Up a level to AcSmViewCategory
AcSmViewCategory.GetOwner Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetOwner() As IAcSmPersist


IAcSmComponent.GetOwner

Up a level to IAcSmComponent
IAcSmComponent.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


IAcSmObjectId.GetOwner

Up a level to IAcSmObjectId
IAcSmObjectId.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

The caller must release the interface when the operation is complete.

Syntax

GetOwner() As IAcSmPersist


IAcSmPersist.GetOwner

Up a level to IAcSmPersist
IAcSmPersist.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

If the method succeeds, the return value is S_OK. If the pointer to the owning IAcSmPersist parent object cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetOwner() As IAcSmPersist


AcSmAcDbBlockRecordReference.GetOwnerAcDbHandle

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.GetOwnerAcDbHandle Method

Retrieves the AcDbHandle of the parent AcDbObject of the referenced object.

Syntax

GetOwnerAcDbHandle() As String


AcSmAcDbLayoutReference.GetOwnerAcDbHandle

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.GetOwnerAcDbHandle Method

Retrieves the AcDbHandle of the parent AcDbObject of the referenced object.

Syntax

GetOwnerAcDbHandle() As String


AcSmAcDbViewReference.GetOwnerAcDbHandle

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.GetOwnerAcDbHandle Method

Retrieves the AcDbHandle of the parent AcDbObject of the referenced object.

Syntax

GetOwnerAcDbHandle() As String


AcSmNamedAcDbObjectReference.GetOwnerAcDbHandle

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.GetOwnerAcDbHandle Method

Retrieves the AcDbHandle of the parent AcDbObject of the referenced object.

Syntax

GetOwnerAcDbHandle() As String


AcSmSheetSetMgr.GetParentSheetSet

Up a level to AcSmSheetSetMgr
AcSmSheetSetMgr.GetParentSheetSet Method

Attempts to find a sheet set that references a file name and layout. Any hints saved in the drawing are used.

The caller must release the interface when the operation is complete.

Syntax

GetParentSheetSet(

dwg As String,

layout As String,

sheetSet As AcSmSheetSet) As IAcSmSheetSet

dwg | Input file name of the drawing that contains the layout
layout | Input name of the layout
sheetSet | Output sheet set that references the file name and layout


AcSmPublishOptions.GetPassword

Up a level to AcSmPublishOptions
AcSmPublishOptions.GetPassword Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetPassword() As String


IAcSmObjectId.GetPersistObject

Up a level to IAcSmObjectId
IAcSmObjectId.GetPersistObject Method

Returns a pointer to the instance of the IAcSmPersist component identified by the IAcSmObjectId.

The caller must release the interface when the operation is complete.

Syntax

GetPersistObject() As IAcSmPersist


AcSmSheetSet.GetProjectMilestone

Up a level to AcSmSheetSet
AcSmSheetSet.GetProjectMilestone Method

Retrieves the ProjectMilestone property. Returns S_OK if successful.

Syntax

GetProjectMilestone(

pVal As BSTR*) As HRESULT

pVal Output pointer to a string containing the value of the ProjectMilestone property


AcSmSheetSet.GetProjectName

Up a level to AcSmSheetSet
AcSmSheetSet.GetProjectName Method

Retrieves the project name associated with this sheet set. Returns S_OK if successful.

Syntax

GetProjectName(

pVal As BSTR*) As HRESULT

pVal Output pointer to a string containing the value of the ProjectName property


AcSmSheetSet.GetProjectNumber

Up a level to AcSmSheetSet
AcSmSheetSet.GetProjectNumber Method

Retrieves the project number associated with this sheet set. Returns S_OK if successful.

Syntax

GetProjectNumber(

pVal As BSTR*) As HRESULT

pVal Output pointer to a string containing the value of the ProjectNumber property


AcSmSheetSet.GetProjectPhase

Up a level to AcSmSheetSet
AcSmSheetSet.GetProjectPhase Method

Retrieves the ProjectPhase property. Returns S_OK if successful.

Syntax

GetProjectPhase(

pVal As BSTR*) As HRESULT

pVal Output pointer to a string containing the value of the ProjectPhase property


AcSmSheetSet.GetPromptForDwgName

Up a level to AcSmSheetSet
AcSmSheetSet.GetPromptForDwgName Method

Retrieves the flag indicating whether the user interface should prompt for the name of a new drawing.

Syntax

GetPromptForDwgName() As Boolean


AcSmSheetSet.GetPromptForDwt

Up a level to AcSmSheetSet
AcSmSheetSet.GetPromptForDwt Method

Returns the Boolean flag that indicates if the application should prompt for DWT file.

Syntax

GetPromptForDwt() As Boolean


AcSmSubset.GetPromptForDwt

Up a level to AcSmSubset
AcSmSubset.GetPromptForDwt Method

Returns a Boolean flag indicating if the application should prompt for a DWT file.

Syntax

GetPromptForDwt() As Boolean


AcSmPublishOptions.GetPromptForName

Up a level to AcSmPublishOptions
AcSmPublishOptions.GetPromptForName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetPromptForName() As Boolean


AcSmPublishOptions.GetPromptForPassword

Up a level to AcSmPublishOptions
AcSmPublishOptions.GetPromptForPassword Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetPromptForPassword() As Boolean


AcSmCustomPropertyBag.GetProperty

Up a level to AcSmCustomPropertyBag
AcSmCustomPropertyBag.GetProperty Method

Retrieves the IAcSmCustomPropertyValue specified with the Name parameter. If the method succeeds, the return value is S_OK. If the custom property value cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmCustomPropertyValue interface when the operation is completed.

Syntax

GetProperty(

name As String) As IAcSmCustomPropertyValue

name Input string containing Name value of a property


AcSmCustomPropertyBag.GetPropertyEnumerator

Up a level to AcSmCustomPropertyBag
AcSmCustomPropertyBag.GetPropertyEnumerator Method

Returns an enumerator of all the contained properties. After an element is returned using the Next method, you can perform operations on it.

The collection should be treated as read-only. Elements should not be removed during iteration because removing elements can result in inconsistencies.

The caller must release the allocated memory when the operation is complete.

Syntax

GetPropertyEnumerator() As IAcSmEnumProperty


AcSmSheetSet.GetPublishOptions

Up a level to AcSmSheetSet
AcSmSheetSet.GetPublishOptions Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetPublishOptions() As IAcSmPublishOptions


AcSmObjectReference.GetReferencedObject

Up a level to AcSmObjectReference
AcSmObjectReference.GetReferencedObject Method

Retrieves the referenced IAcSmPersist object.

The caller must release the interface when the operation is complete.

Syntax

GetReferencedObject() As IAcSmPersist


AcSmObjectReference.GetReferenceFlags

Up a level to AcSmObjectReference
AcSmObjectReference.GetReferenceFlags Method

Retrieves the reference flags to determine the type of referencing used, hard referencing or soft referencing.

Syntax

GetReferenceFlags() As AcSmObjectReferenceFlags


AcSmSheetSet.GetResources

Up a level to AcSmSheetSet
AcSmSheetSet.GetResources Method

Returns a collection of the resources associated with the sheet set.

The caller must release the interface when the operation is complete.

Syntax

GetResources() As IAcSmResources


AcSmSheet.GetRevisionDate

Up a level to AcSmSheet
AcSmSheet.GetRevisionDate Method

Retrieves the RevisionDate property. Returns S_OK if successful.

Syntax

GetRevisionDate(

pVal As BSTR*) As HRESULT

pVal Output pointer to a string containing the value of the RevisionDate property


AcSmDSTFiler.GetRevisionNumber

Up a level to AcSmDSTFiler
AcSmDSTFiler.GetRevisionNumber Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetRevisionNumber() As Long


AcSmSheet.GetRevisionNumber

Up a level to AcSmSheet
AcSmSheet.GetRevisionNumber Method

Retrieves the RevisionNumber property. Returns S_OK if successful.

Syntax

GetRevisionNumber(

pVal As BSTR*) As HRESULT

pVal Output pointer to a string containing the value of the RevisionNumber property


AcSmSheetSet.GetSheetEnumerator

Up a level to AcSmSheetSet
AcSmSheetSet.GetSheetEnumerator Method

Returns an enumerator of all components contained in this subset (ordered).

Syntax

GetSheetEnumerator() As IAcSmEnumComponent


AcSmSubset.GetSheetEnumerator

Up a level to AcSmSubset
AcSmSubset.GetSheetEnumerator Method

Returns an enumerator of all components in this subset.

The caller must release the interface when the operation is complete.

Syntax

GetSheetEnumerator() As IAcSmEnumComponent


AcSmSheetSet.GetSheetSelSets

Up a level to AcSmSheetSet
AcSmSheetSet.GetSheetSelSets Method

Returns a collection of the sheet selection sets associated with the sheet set.

The caller must release the interface when the operation is complete.

Syntax

GetSheetSelSets() As IAcSmSheetSelSets


AcSmDatabase.GetSheetSet

Up a level to AcSmDatabase
AcSmDatabase.GetSheetSet Method

Retrieves the IAcSmSheetSet component contained in the database.

The caller must release the interface when the operation is complete.

Syntax

GetSheetSet() As IAcSmSheetSet


AcSmViewCategory.GetSheetViewEnumerator

Up a level to AcSmViewCategory
AcSmViewCategory.GetSheetViewEnumerator Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetSheetViewEnumerator() As IAcSmEnumSheetView


AcSmSheet.GetSheetViews

Up a level to AcSmSheet
AcSmSheet.GetSheetViews Method

Retreives the sheet views collection of the sheet.

The caller must release the interface when the operation is complete.

Syntax

GetSheetViews() As IAcSmSheetViews


AcSmDatabase.GetTemplateDstFileName

Up a level to AcSmDatabase
AcSmDatabase.GetTemplateDstFileName Method

Gets the file name of the template DST file specified with the LoadFromFile method when the database object was created.

This is a read-only value that is set only when a database object is initially loaded from a template.

Syntax

GetTemplateDstFileName() As String


AcSmSheet.GetTitle

Up a level to AcSmSheet
AcSmSheet.GetTitle Method

Retrieves the title of the sheet.

Syntax

GetTitle() As String


AcSmSheetView.GetTitle

Up a level to AcSmSheetView
AcSmSheetView.GetTitle Method

Retrieves the Title property of the sheet view.

Syntax

GetTitle() As String


AcSmAcDbBlockRecordReference.GetTypeName

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmAcDbLayoutReference.GetTypeName

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmAcDbObjectReference.GetTypeName

Up a level to AcSmAcDbObjectReference
AcSmAcDbObjectReference.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmAcDbViewReference.GetTypeName

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmCalloutBlockReferences.GetTypeName

Up a level to AcSmCalloutBlockReferences
AcSmCalloutBlockReferences.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmCalloutBlocks.GetTypeName

Up a level to AcSmCalloutBlocks
AcSmCalloutBlocks.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmCustomPropertyBag.GetTypeName

Up a level to AcSmCustomPropertyBag
AcSmCustomPropertyBag.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmCustomPropertyValue.GetTypeName

Up a level to AcSmCustomPropertyValue
AcSmCustomPropertyValue.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmDatabase.GetTypeName

Up a level to AcSmDatabase
AcSmDatabase.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmFileReference.GetTypeName

Up a level to AcSmFileReference
AcSmFileReference.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmNamedAcDbObjectReference.GetTypeName

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmObjectReference.GetTypeName

Up a level to AcSmObjectReference
AcSmObjectReference.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmPersistProxy.GetTypeName

Up a level to AcSmPersistProxy
AcSmPersistProxy.GetTypeName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetTypeName() As String


AcSmPublishOptions.GetTypeName

Up a level to AcSmPublishOptions
AcSmPublishOptions.GetTypeName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetTypeName() As String


AcSmResources.GetTypeName

Up a level to AcSmResources
AcSmResources.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmSheet.GetTypeName

Up a level to AcSmSheet
AcSmSheet.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmSheetSelSet.GetTypeName

Up a level to AcSmSheetSelSet
AcSmSheetSelSet.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmSheetSelSets.GetTypeName

Up a level to AcSmSheetSelSets
AcSmSheetSelSets.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmSheetSet.GetTypeName

Up a level to AcSmSheetSet
AcSmSheetSet.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmSheetView.GetTypeName

Up a level to AcSmSheetView
AcSmSheetView.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmSheetViews.GetTypeName

Up a level to AcSmSheetViews
AcSmSheetViews.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmSubset.GetTypeName

Up a level to AcSmSubset
AcSmSubset.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmViewCategories.GetTypeName

Up a level to AcSmViewCategories
AcSmViewCategories.GetTypeName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetTypeName() As String


AcSmViewCategory.GetTypeName

Up a level to AcSmViewCategory
AcSmViewCategory.GetTypeName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetTypeName() As String


IAcSmComponent.GetTypeName

Up a level to IAcSmComponent
IAcSmComponent.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


IAcSmPersist.GetTypeName

Up a level to IAcSmPersist
IAcSmPersist.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmPublishOptions.GetUnrecognizedData

Up a level to AcSmPublishOptions
AcSmPublishOptions.GetUnrecognizedData Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetUnrecognizedData() As Object


AcSmPublishOptions.GetUnrecognizedSections

Up a level to AcSmPublishOptions
AcSmPublishOptions.GetUnrecognizedSections Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetUnrecognizedSections() As Object


AcSmPublishOptions.GetUsePassword

Up a level to AcSmPublishOptions
AcSmPublishOptions.GetUsePassword Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetUsePassword() As Boolean


AcSmCustomPropertyValue.GetValue

Up a level to AcSmCustomPropertyValue
AcSmCustomPropertyValue.GetValue Method

Retrieves the variant value associated with the custom property.

Syntax

GetValue() As Variant


AcSmSheetSet.GetViewCategories

Up a level to AcSmSheetSet
AcSmSheetSet.GetViewCategories Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetViewCategories() As IAcSmViewCategories


AcSmSheetSet.ImportSheet

Up a level to AcSmSheetSet
AcSmSheetSet.ImportSheet Method

Constructs a new sheet component that references the existing layout pointed to by the provided AcSmAcDbLayoutReference.

Syntax

ImportSheet(

pLayoutRef As IAcSmAcDbLayoutReference) As IAcSmAcDbLayoutReference

pLayoutRef Input layout reference


AcSmSubset.ImportSheet

Up a level to AcSmSubset
AcSmSubset.ImportSheet Method

Adds a new sheet component that references the layout of AcSmAcDbLayoutReference. The new component is not added to the subset.

To add the new sheet component to the subset, use the InsertComponent method.

Syntax

ImportSheet(

pLayoutRef As IAcSmAcDbLayoutReference) As IAcSmSheet

pLayoutRef Input drawing and layout to be imported


AcSmDSTFiler.Init

Up a level to AcSmDSTFiler
AcSmDSTFiler.Init Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Init(

pUnk As Object,

pDb As IAcSmDatabase,

bForWrite As Boolean) As Object

pUnk | Input IUnknown pointer representing the data container construct object
pDb | Input IAcSmDatabase that the filer will act on
bForWrite | Input Boolean to indicate if the filer will perform read operations or write operations


AcSmAcDbBlockRecordReference.InitNew

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmAcDbLayoutReference.InitNew

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmAcDbObjectReference.InitNew

Up a level to AcSmAcDbObjectReference
AcSmAcDbObjectReference.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmAcDbViewReference.InitNew

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmCalloutBlockReferences.InitNew

Up a level to AcSmCalloutBlockReferences
AcSmCalloutBlockReferences.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmCalloutBlocks.InitNew

Up a level to AcSmCalloutBlocks
AcSmCalloutBlocks.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmCustomPropertyBag.InitNew

Up a level to AcSmCustomPropertyBag
AcSmCustomPropertyBag.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmCustomPropertyValue.InitNew

Up a level to AcSmCustomPropertyValue
AcSmCustomPropertyValue.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmDatabase.InitNew

Up a level to AcSmDatabase
AcSmDatabase.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmFileReference.InitNew

Up a level to AcSmFileReference
AcSmFileReference.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmNamedAcDbObjectReference.InitNew

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmObjectReference.InitNew

Up a level to AcSmObjectReference
AcSmObjectReference.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmPersistProxy.InitNew

Up a level to AcSmPersistProxy
AcSmPersistProxy.InitNew Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmPublishOptions.InitNew

Up a level to AcSmPublishOptions
AcSmPublishOptions.InitNew Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmResources.InitNew

Up a level to AcSmResources
AcSmResources.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmSheet.InitNew

Up a level to AcSmSheet
AcSmSheet.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmSheetSelSet.InitNew

Up a level to AcSmSheetSelSet
AcSmSheetSelSet.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmSheetSelSets.InitNew

Up a level to AcSmSheetSelSets
AcSmSheetSelSets.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmSheetSet.InitNew

Up a level to AcSmSheetSet
AcSmSheetSet.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmSheetView.InitNew

Up a level to AcSmSheetView
AcSmSheetView.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmSheetViews.InitNew

Up a level to AcSmSheetViews
AcSmSheetViews.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmSubset.InitNew

Up a level to AcSmSubset
AcSmSubset.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmViewCategories.InitNew

Up a level to AcSmViewCategories
AcSmViewCategories.InitNew Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmViewCategory.InitNew

Up a level to AcSmViewCategory
AcSmViewCategory.InitNew Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


IAcSmComponent.InitNew

Up a level to IAcSmComponent
IAcSmComponent.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


IAcSmPersist.InitNew

Up a level to IAcSmPersist
IAcSmPersist.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmSheetSet.InsertComponent

Up a level to AcSmSheetSet
AcSmSheetSet.InsertComponent Method

Inserts a sheet at the position specified.

Syntax

InsertComponent(

newSheet As IAcSmComponent,

beforeComp As IAcSmComponent) As Object

newSheet | Input IAcSmComponent to be inserted
beforeComp | Input IAcSmComponent before which the component will be inserted, or specify null if the component should be inserted at the end of the subset


AcSmSubset.InsertComponent

Up a level to AcSmSubset
AcSmSubset.InsertComponent Method

Inserts a sheet at the position specified.

Syntax

InsertComponent(

newSheet As IAcSmComponent,

beforeComp As IAcSmComponent) As Object

newSheet | Input IAcSmComponent to be inserted
beforeComp | Input location of the new sheet, or null to insert the sheet at the end of the subset


AcSmSheetSet.InsertComponentAfter

Up a level to AcSmSheetSet
AcSmSheetSet.InsertComponentAfter Method

Inserts a sheet at the position specified.

Syntax

InsertComponentAfter(

newSheet As IAcSmComponent,

afterComp As IAcSmComponent) As Object

newSheet | Input IAcSmComponent to be inserted
afterComp | Input component after which to insert the sheet


AcSmSubset.InsertComponentAfter

Up a level to AcSmSubset
AcSmSubset.InsertComponentAfter Method

Inserts a sheet at the position specified.

Syntax

InsertComponentAfter(

newSheet As IAcSmComponent,

afterComp As IAcSmComponent) As Object

newSheet | Input IAcSmComponent to be inserted
afterComp | Input location of the new sheet, or null to insert the sheet at the beginning of the subset


IAcSmObjectId.IsEqual

Up a level to IAcSmObjectId
IAcSmObjectId.IsEqual Method

Compares one IAcSmObjectId with another IAcSmObjectId object, and returns True if both objects reference the same component.

Syntax

IsEqual(

pId As IAcSmObjectId) As Boolean

pId Input IAcSmObjectId for comparison


IAcSmObjectId.IsValid

Up a level to IAcSmObjectId
IAcSmObjectId.IsValid Method

Determines whether an IAcSmObjectId points to a valid object.

Syntax

IsValid() As Boolean


AcSmAcDbBlockRecordReference.Load

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load() As Object


AcSmAcDbLayoutReference.Load

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load() As Object


AcSmAcDbObjectReference.Load

Up a level to AcSmAcDbObjectReference
AcSmAcDbObjectReference.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmAcDbViewReference.Load

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load() As Object


AcSmCalloutBlockReferences.Load

Up a level to AcSmCalloutBlockReferences
AcSmCalloutBlockReferences.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmCalloutBlocks.Load

Up a level to AcSmCalloutBlocks
AcSmCalloutBlocks.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmCustomPropertyBag.Load

Up a level to AcSmCustomPropertyBag
AcSmCustomPropertyBag.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmCustomPropertyValue.Load

Up a level to AcSmCustomPropertyValue
AcSmCustomPropertyValue.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmDatabase.Load

Up a level to AcSmDatabase
AcSmDatabase.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmFileReference.Load

Up a level to AcSmFileReference
AcSmFileReference.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmNamedAcDbObjectReference.Load

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmObjectReference.Load

Up a level to AcSmObjectReference
AcSmObjectReference.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmPersistProxy.Load

Up a level to AcSmPersistProxy
AcSmPersistProxy.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmPublishOptions.Load

Up a level to AcSmPublishOptions
AcSmPublishOptions.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmResources.Load

Up a level to AcSmResources
AcSmResources.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmSheet.Load

Up a level to AcSmSheet
AcSmSheet.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmSheetSelSet.Load

Up a level to AcSmSheetSelSet
AcSmSheetSelSet.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmSheetSelSets.Load

Up a level to AcSmSheetSelSets
AcSmSheetSelSets.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmSheetSet.Load

Up a level to AcSmSheetSet
AcSmSheetSet.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmSheetView.Load

Up a level to AcSmSheetView
AcSmSheetView.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmSheetViews.Load

Up a level to AcSmSheetViews
AcSmSheetViews.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmSubset.Load

Up a level to AcSmSubset
AcSmSubset.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmViewCategories.Load

Up a level to AcSmViewCategories
AcSmViewCategories.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmViewCategory.Load

Up a level to AcSmViewCategory
AcSmViewCategory.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


IAcSmComponent.Load

Up a level to IAcSmComponent
IAcSmComponent.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


IAcSmPersist.Load

Up a level to IAcSmPersist
IAcSmPersist.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmDatabase.LoadFromFile

Up a level to AcSmDatabase
AcSmDatabase.LoadFromFile Method

Clears the contents of the database and loads data from a file. The file name property of the database is unchanged; the original file name is used by the GetFileName method and the original file name is used when data is written to the disk.

The file name can be null if you want to load or reload data from the current file name.

Syntax

LoadFromFile(

templateDstFileName As String = 0) As Object

templateDstFileName Input name of the file from which to load data


AcSmDatabase.LockDb

Up a level to AcSmDatabase
AcSmDatabase.LockDb Method

Locks the database so it can be modified.

Syntax

LockDb(

pObject As Object) As Object

pObject Input any valid IUnknown pointer as the owner of the requested lock


IAcSmEnumAcDbBlockRecordReference.Next

Up a level to IAcSmEnumAcDbBlockRecordReference
IAcSmEnumAcDbBlockRecordReference.Next Method

Iterates to the next component and retrieves it. For an example of how to use the Next method in VBA, see Reliably Access Sheet Set Components.

Syntax

Next() As AcSmAcDbBlockRecordReference


IAcSmEnumComponent.Next

Up a level to IAcSmEnumComponent
IAcSmEnumComponent.Next Method

Iterates to the next component and retrieves it. For an example of how to use the Next method in VBA, see Reliably Access Sheet Set Components.

After an element is returned using the Next method, you can perform operations on it. The collection should be treated as read-only. Elements should not be removed during iteration because removing elements can result in inconsistencies.

If the return value is S_OK, iteration can continue. If the return value is S_FALSE, iteration must stop. Do not use the macro SUCCEEDED to determine success or failure.

The caller must release the interface when the operation is complete.

Syntax

Next() As IAcSmComponent


IAcSmEnumDatabase.Next

Up a level to IAcSmEnumDatabase
IAcSmEnumDatabase.Next Method

Iterates to the next component and retrieves it.

Syntax

Next() As IAcSmDatabase


IAcSmEnumFileReference.Next

Up a level to IAcSmEnumFileReference
IAcSmEnumFileReference.Next Method

Iterates to the next component and retrieves it. For an example of how to use the Next method in VBA, see Reliably Access Sheet Set Components.

After an element is returned using the Next method, you can perform operations on it. The collection should be treated as read-only. Elements should not be removed during iteration because removing elements can result in inconsistencies.

If the return value is S_OK, iteration can continue. If the return value is S_FALSE, iteration must stop. The macro SUCCEEDED should not be used to determine success or failure.

The caller must release the interface when the operation is complete.

Syntax

Next() As IAcSmFileReference


IAcSmEnumPersist.Next

Up a level to IAcSmEnumPersist
IAcSmEnumPersist.Next Method

Iterates through a collection and returns an element. For an example of how to use the Next method in VBA, see Reliably Access Sheet Set Components.

After an element is returned, you can perform operations on it. The collection should be treated as read-only. Elements should not be removed during iteration because removing elements can result in inconsistencies.

The caller must release the interface when the operation is complete.

If the return value is S_OK, then iteration should continue. If the return value is S_FALSE, then iteration should stop.

Syntax

Next() As IAcSmPersist


IAcSmEnumProperty.Next

Up a level to IAcSmEnumProperty
IAcSmEnumProperty.Next Method

Iterates to the next component and retrieves it. For an example of how to use the Next method in VBA, see Reliably Access Sheet Set Components.

After an element is returned using the Next method, you can perform operations on it. The collection should be treated as read-only. Elements should not be removed during iteration because removing elements can result in inconsistencies.

The caller must release the allocated data and the interface when the operation is complete.

Syntax

Next(

propname As String,

ppValue As IAcSmCustomPropertyValue) As Object

propname | Output pointer to the name of the property
ppValue | Output pointer to an appropriately allocated and initialized IAcSmCustomPropertyValue object


IAcSmEnumSheetSelSet.Next

Up a level to IAcSmEnumSheetSelSet
IAcSmEnumSheetSelSet.Next Method

Iterates to the next component and retrieves it.

After an element is returned using the Next method, you can perform operations on it. The collection should be treated as read-only. Elements should not be removed during iteration because removing elements can result in inconsistencies.

If the return value is S_OK, iteration can continue. If the return value is S_FALSE, iteration must stop. The macro SUCCEEDED should not be used to determine success or failure.

The caller must release the interface when the operation is complete.

Syntax

Next() As IAcSmSheetSelSet


IAcSmEnumSheetView.Next

Up a level to IAcSmEnumSheetView
IAcSmEnumSheetView.Next Method

Iterates to the next component and retrieves it.

After an element is returned using the Next method, you can perform operations on it. The collection should be treated as read-only. Elements should not be removed during iteration because removing elements can result in inconsistencies.

If the return value is S_OK, iteration can continue. If the return value is S_FALSE, iteration must stop. The macro SUCCEEDED should not be used to determine success or failure.

The caller must release the interface when the operation is complete.

Syntax

Next() As IAcSmSheetView


IAcSmEnumViewCategory.Next

Up a level to IAcSmEnumViewCategory
IAcSmEnumViewCategory.Next Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Next() As IAcSmViewCategory


AcSmDatabase.NotifyRegisteredEventHandlers

Up a level to AcSmDatabase
AcSmDatabase.NotifyRegisteredEventHandlers Method

Forces a notification to all registered notification handlers.

Syntax

NotifyRegisteredEventHandlers(

eventcode As __MIDL___MIDL_itf_AcSmComponents_0265_0001,

comp As IAcSmPersist) As Object

eventcode | Input event code
comp | Input component affected by the event


AcSmSheetSet.NotifyRegisteredEventHandlers

Up a level to AcSmSheetSet
AcSmSheetSet.NotifyRegisteredEventHandlers Method

Forces a given notification to all registered notification handlers.

Syntax

NotifyRegisteredEventHandlers(

eventcode As __MIDL___MIDL_itf_AcSmComponents_0265_0001,

comp As IAcSmPersist) As Object

eventcode | Input event code
comp | Input component


AcSmSubset.NotifyRegisteredEventHandlers

Up a level to AcSmSubset
AcSmSubset.NotifyRegisteredEventHandlers Method

Forces a notification to all registered notification handlers.

Syntax

NotifyRegisteredEventHandlers(

eventcode As __MIDL___MIDL_itf_AcSmComponents_0265_0001,

comp As IAcSmPersist) As Object

eventcode | Input event code
comp | Input component affected by the event


IAcSmEvents.OnChanged

Up a level to IAcSmEvents
IAcSmEvents.OnChanged Method

Notification of an event.

Syntax

OnChanged(

eventcode As __MIDL___MIDL_itf_AcSmComponents_0265_0001,

comp As IAcSmPersist) As Object

eventcode | Input event code
comp | Input component affected by the event


AcSmSheetSetMgr.OpenDatabase

Up a level to AcSmSheetSetMgr
AcSmSheetSetMgr.OpenDatabase Method

Opens an existing database and returns the new IAcSmDatabase component for it.

The caller must release the interface when the operation is complete.

Syntax

OpenDatabase(

filename As String,

bFailIfAlreadyOpen As Boolean = True) As IAcSmDatabase

filename | Input name of the file to open
bFailIfAlreadyOpen | Input Boolean indicating whether the method should fail if the file is already open


AcSmDSTFiler.PopCurrentReadObject

Up a level to AcSmDSTFiler
AcSmDSTFiler.PopCurrentReadObject Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

PopCurrentReadObject(

bSuccess As Long) As Object

bSuccess Input long; if the input value is zero, then the object read should not be added to the in-memory graph


AcSmDSTFiler.PopCurrentWriteObject

Up a level to AcSmDSTFiler
AcSmDSTFiler.PopCurrentWriteObject Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

PopCurrentWriteObject(

bSuccess As Long) As Object

bSuccess Input long; if the input value is not zero, then the pushed write object should be written out


AcSmDSTFiler.PushCurrentReadObject

Up a level to AcSmDSTFiler
AcSmDSTFiler.PushCurrentReadObject Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

PushCurrentReadObject(

pObj As IAcSmPersist) As Object

pObj Input pointer to the IAcSmPersist object that is being read


AcSmDSTFiler.PushCurrentWriteObject

Up a level to AcSmDSTFiler
AcSmDSTFiler.PushCurrentWriteObject Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

PushCurrentWriteObject(

pObj As IAcSmPersist) As Object

pObj Input pointer to an IAcSmPersist object to push onto the stack


AcSmDSTFiler.ReadObject

Up a level to AcSmDSTFiler
AcSmDSTFiler.ReadObject Method

This API was designed for internal use and has not been thoroughly tested.

The caller must release the IAcSmPersist object when the operation is completed.

Syntax

ReadObject() As IAcSmPersist


AcSmDSTFiler.ReadProperty

Up a level to AcSmDSTFiler
AcSmDSTFiler.ReadProperty Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

ReadProperty(

ppPropname As String,

pVal As Variant) As Object

ppPropname | Output pointer to a string indicating the name of the property that is being read
pVal | Output pointer to a variant indicating the value of the property that is being read


AcSmDSTFiler.ReadRawData

Up a level to AcSmDSTFiler
AcSmDSTFiler.ReadRawData Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

ReadRawData(

p As Byte,

count As Long) As Object

p | Output pointer to the raw data buffer
count | Output pointer to the size of the raw data buffer


AcSmDatabase.Register

Up a level to AcSmDatabase
AcSmDatabase.Register Method

Registers a callback notification handler and returns a unique cookie for the handler.

Syntax

Register(

eventHandler As IAcSmEvents) As Long

eventHandler Input pointer to an IAcSmEvents interface


AcSmSheetSet.Register

Up a level to AcSmSheetSet
AcSmSheetSet.Register Method

Registers a callback notification handler and returns a unique cookie identifier for the handler.

Syntax

Register(

eventHandler As IAcSmEvents) As Long

eventHandler Input IAcSmEvents interface


AcSmSheetSetMgr.Register

Up a level to AcSmSheetSetMgr
AcSmSheetSetMgr.Register Method

Registers a handler for callback notification. Returns a unique cookie for the handler.

Syntax

Register(

eventHandler As IAcSmEvents) As Long

eventHandler Input pointer to an event handler


AcSmDatabase.RegisterOwner

Up a level to AcSmDatabase
AcSmDatabase.RegisterOwner Method

Provides a way to construct component graphs using the idCookie parameter as a security key.

Syntax

RegisterOwner(

idcookie As Long,

pObject As IAcSmPersist,

pOwner As IAcSmPersist) As Object

idcookie | Input security key
pObject | Input object
pOwner | Input pointer to the owner of the object


AcSmCalloutBlockReferences.Remove

Up a level to AcSmCalloutBlockReferences
AcSmCalloutBlockReferences.Remove Method

Removes the specified AcSmAcDbBlockRecordReference component from the collection.

Syntax

Remove(

pBlkRef As IAcSmAcDbBlockRecordReference) As Object

pBlkRef Input component to be removed


AcSmCalloutBlocks.Remove

Up a level to AcSmCalloutBlocks
AcSmCalloutBlocks.Remove Method

Removes an IAcSmAcDbBlockRecordReference component from the collection.

Syntax

Remove(

pBlkRef As IAcSmAcDbBlockRecordReference) As Object

pBlkRef Input AcSmAcDbBlockRecordReference component to remove from the collection


AcSmResources.Remove

Up a level to AcSmResources
AcSmResources.Remove Method

Removes an IAcSmFileReference component from the collection.

Syntax

Remove(

pResource As IAcSmFileReference) As Object

pResource Input IAcSmFileReference component to remove from the collection


AcSmSheetSelSet.Remove

Up a level to AcSmSheetSelSet
AcSmSheetSelSet.Remove Method

Removes a component from the selection set.

Syntax

Remove(

comp As IAcSmComponent) As Object

comp Input sheet or subset to be removed from the selection set


AcSmSheetSelSets.Remove

Up a level to AcSmSheetSelSets
AcSmSheetSelSets.Remove Method

Removes a selection set component from the collection.

Syntax

Remove(

selset As IAcSmSheetSelSet) As Object

selset Input selection set component to remove from the collection


AcSmSheetSet.RemoveSheet

Up a level to AcSmSheetSet
AcSmSheetSet.RemoveSheet Method

Removes the specified sheet component from the collection.

Syntax

RemoveSheet(

sheet As IAcSmSheet) As Object

sheet Input IAcSmSheet to be removed


AcSmSubset.RemoveSheet

Up a level to AcSmSubset
AcSmSubset.RemoveSheet Method

Removes the specified sheet component from the subset.

Syntax

RemoveSheet(

sheet As IAcSmSheet) As Object

sheet Input sheet to be removed from the subset


AcSmSheetSet.RemoveSubset

Up a level to AcSmSheetSet
AcSmSheetSet.RemoveSubset Method

Removes the specified subset component from the collection.

Syntax

RemoveSubset(

subset As IAcSmSubset) As Object

subset Input subset component to be removed


AcSmSubset.RemoveSubset

Up a level to AcSmSubset
AcSmSubset.RemoveSubset Method

Removes the specified subset component from the collection.

Syntax

RemoveSubset(

subset As IAcSmSubset) As Object

subset Input subset to be removed


AcSmViewCategories.RemoveViewCategory

Up a level to AcSmViewCategories
AcSmViewCategories.RemoveViewCategory Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

RemoveViewCategory(

viewCat As IAcSmViewCategory) As Object

viewCat View category


IAcSmEnumAcDbBlockRecordReference.Reset

Up a level to IAcSmEnumAcDbBlockRecordReference
IAcSmEnumAcDbBlockRecordReference.Reset Method

Resets the iterator to the position before the first element.

Syntax

Reset() As Object


IAcSmEnumComponent.Reset

Up a level to IAcSmEnumComponent
IAcSmEnumComponent.Reset Method

Resets the iterator to the position before the first element.

Syntax

Reset() As Object


IAcSmEnumDatabase.Reset

Up a level to IAcSmEnumDatabase
IAcSmEnumDatabase.Reset Method

Resets the iterator to the position before the first element.

Syntax

Reset() As Object


IAcSmEnumFileReference.Reset

Up a level to IAcSmEnumFileReference
IAcSmEnumFileReference.Reset Method

Resets the iterator to the position before the first element.

Syntax

Reset() As Object


IAcSmEnumPersist.Reset

Up a level to IAcSmEnumPersist
IAcSmEnumPersist.Reset Method

Resets the iterator to the position before the first element.

Syntax

Reset() As Object


IAcSmEnumProperty.Reset

Up a level to IAcSmEnumProperty
IAcSmEnumProperty.Reset Method

Resets the iterator to the position before the first element.

Syntax

Reset() As Object


IAcSmEnumSheetSelSet.Reset

Up a level to IAcSmEnumSheetSelSet
IAcSmEnumSheetSelSet.Reset Method

Resets the iterator to the position before the first element.

Syntax

Reset() As Object


IAcSmEnumSheetView.Reset

Up a level to IAcSmEnumSheetView
IAcSmEnumSheetView.Reset Method

Resets the iterator to the position before the first element.

Syntax

Reset() As Object


IAcSmEnumViewCategory.Reset

Up a level to IAcSmEnumViewCategory
IAcSmEnumViewCategory.Reset Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Reset() As Object


AcSmAcDbBlockRecordReference.ResolveAcDbObject

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.ResolveAcDbObject Method

Attempts to find the referenced AcDbObject in the specified AcDbDatabase.

Syntax

ResolveAcDbObject(

pAcDbDatabase As AcadDatabase) As String

pAcDbDatabase Input string that indicates the AcadDatabase in which to find the referenced AcDbObject


AcSmAcDbLayoutReference.ResolveAcDbObject

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.ResolveAcDbObject Method

Attempts to find the referenced AcDbObject in the specified AcDbDatabase.

Syntax

ResolveAcDbObject(

pAcDbDatabase As AcadDatabase) As String

pAcDbDatabase Input string that indicates the AcadDatabase in which to find the referenced AcDbObject


AcSmAcDbObjectReference.ResolveAcDbObject

Up a level to AcSmAcDbObjectReference
AcSmAcDbObjectReference.ResolveAcDbObject Method

Attempts to find the referenced AcDbObject in the specified AcDbDatabase.

Syntax

ResolveAcDbObject(

pAcDbDatabase As AcadDatabase) As String

pAcDbDatabase Input string that indicates the AcadDatabase in which to find the referenced AcDbObject


AcSmAcDbViewReference.ResolveAcDbObject

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.ResolveAcDbObject Method

Attempts to find the referenced AcDbObject in the specified AcDbDatabase.

Syntax

ResolveAcDbObject(

pAcDbDatabase As AcadDatabase) As String

pAcDbDatabase Input string that indicates the AcadDatabase in which to find the referenced AcDbObject


AcSmNamedAcDbObjectReference.ResolveAcDbObject

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.ResolveAcDbObject Method

Attempts to find the referenced AcDbObject in the specified AcDbDatabase.

Syntax

ResolveAcDbObject(

pAcDbDatabase As AcadDatabase) As String

pAcDbDatabase Input string that indicates the AcadDatabase in which to find the referenced AcDbObject


AcSmAcDbBlockRecordReference.ResolveFileName

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.ResolveFileName Method

Retrieves the fully qualified path to the resolved file name. S_FALSE is returned if the file is not found.

Syntax

ResolveFileName() As String


AcSmAcDbLayoutReference.ResolveFileName

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.ResolveFileName Method

Retrieves the fully qualified path to the resolved file name. S_FALSE is returned if the file is not found.

Syntax

ResolveFileName() As String


AcSmAcDbObjectReference.ResolveFileName

Up a level to AcSmAcDbObjectReference
AcSmAcDbObjectReference.ResolveFileName Method

Retrieves the fully qualified path to the resolved file name. S_FALSE is returned if the file is not found.

Syntax

ResolveFileName() As String


AcSmAcDbViewReference.ResolveFileName

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.ResolveFileName Method

Retrieves the fully qualified path to the resolved file name. S_FALSE is returned if the file is not found.

Syntax

ResolveFileName() As String


AcSmFileReference.ResolveFileName

Up a level to AcSmFileReference
AcSmFileReference.ResolveFileName Method

Retrieves the fully qualified path to the resolved file name. If the file is not found, the GetReference method can be used to get the stored file name and path.

Syntax

ResolveFileName() As String


AcSmNamedAcDbObjectReference.ResolveFileName

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.ResolveFileName Method

Retrieves the fully qualified path to the resolved file name. S_FALSE is returned if the file is not found.

Syntax

ResolveFileName() As String


AcSmAcDbBlockRecordReference.Save

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save() As Object


AcSmAcDbLayoutReference.Save

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save() As Object


AcSmAcDbObjectReference.Save

Up a level to AcSmAcDbObjectReference
AcSmAcDbObjectReference.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmAcDbViewReference.Save

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save() As Object


AcSmCalloutBlockReferences.Save

Up a level to AcSmCalloutBlockReferences
AcSmCalloutBlockReferences.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmCalloutBlocks.Save

Up a level to AcSmCalloutBlocks
AcSmCalloutBlocks.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmCustomPropertyBag.Save

Up a level to AcSmCustomPropertyBag
AcSmCustomPropertyBag.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmCustomPropertyValue.Save

Up a level to AcSmCustomPropertyValue
AcSmCustomPropertyValue.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmDatabase.Save

Up a level to AcSmDatabase
AcSmDatabase.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmFileReference.Save

Up a level to AcSmFileReference
AcSmFileReference.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmNamedAcDbObjectReference.Save

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmObjectReference.Save

Up a level to AcSmObjectReference
AcSmObjectReference.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmPersistProxy.Save

Up a level to AcSmPersistProxy
AcSmPersistProxy.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmPublishOptions.Save

Up a level to AcSmPublishOptions
AcSmPublishOptions.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmResources.Save

Up a level to AcSmResources
AcSmResources.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmSheet.Save

Up a level to AcSmSheet
AcSmSheet.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmSheetSelSet.Save

Up a level to AcSmSheetSelSet
AcSmSheetSelSet.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmSheetSelSets.Save

Up a level to AcSmSheetSelSets
AcSmSheetSelSets.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmSheetSet.Save

Up a level to AcSmSheetSet
AcSmSheetSet.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmSheetView.Save

Up a level to AcSmSheetView
AcSmSheetView.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmSheetViews.Save

Up a level to AcSmSheetViews
AcSmSheetViews.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmSubset.Save

Up a level to AcSmSubset
AcSmSubset.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmViewCategories.Save

Up a level to AcSmViewCategories
AcSmViewCategories.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmViewCategory.Save

Up a level to AcSmViewCategory
AcSmViewCategory.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


IAcSmComponent.Save

Up a level to IAcSmComponent
IAcSmComponent.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


IAcSmPersist.Save

Up a level to IAcSmPersist
IAcSmPersist.Save Method

Saves the object to the provided filer. This method is called when the component needs to be serialized using an IAcSmFiler object.

Syntax

Save(

pFiler As IAcSmFiler) As Object

pFiler Input filer


AcSmAcDbBlockRecordReference.SetAcDbHandle

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.SetAcDbHandle Method

Sets the AcDbHandle that the object will reference. The name, without the handle, provides insufficient information about the referenced AcDbObject.

Syntax

SetAcDbHandle(

handle As String) As Object

handle Input string that indicates the AcDbHandle to set


AcSmAcDbLayoutReference.SetAcDbHandle

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.SetAcDbHandle Method

Sets the AcDbHandle that the object will reference. The name, without the handle, provides insufficient information about the referenced AcDbObject.

Syntax

SetAcDbHandle(

handle As Object) As Object

handle Input string that indicates the AcDbHandle to set


AcSmAcDbObjectReference.SetAcDbHandle

Up a level to AcSmAcDbObjectReference
AcSmAcDbObjectReference.SetAcDbHandle Method

Sets the AcDbHandle that the object will reference.

Syntax

SetAcDbHandle(

handle As String) As Object

handle Input string that indicates the AcDbHandle to set


AcSmAcDbViewReference.SetAcDbHandle

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.SetAcDbHandle Method

Sets the AcDbHandle that the object will reference. The name, without the handle, provides insufficient information about the referenced AcDbObject.

Syntax

SetAcDbHandle(

handle As String) As Object

handle Input string that indicates the AcDbHandle to set


AcSmNamedAcDbObjectReference.SetAcDbHandle

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.SetAcDbHandle Method

Sets the AcDbHandle that the object will reference. The name, without the handle, provides insufficient information about the referenced AcDbObject.

Syntax

SetAcDbHandle(

handle As String) As Object

handle Input string that indicates the AcDbHandle to set


AcSmAcDbBlockRecordReference.SetAcDbObject

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.SetAcDbObject Method

Sets and modifies all properties of the object reference specified by the AcDbObject pointer.

This method is recommended for initializing an AcSmAcDbObjectReference object.

Syntax

SetAcDbObject() As Object


AcSmAcDbLayoutReference.SetAcDbObject

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.SetAcDbObject Method

Sets and modifies all properties of the object reference specified by the AcDbObject pointer.

This method is recommended for initializing an AcSmAcDbObjectReference object.

Syntax

SetAcDbObject() As Object


AcSmAcDbObjectReference.SetAcDbObject

Up a level to AcSmAcDbObjectReference
AcSmAcDbObjectReference.SetAcDbObject Method

Sets and modifies all properties of the object reference specified by the AcDbObject pointer.

This method is recommended for initializing an IAcSmAcDbObjectReference object.

Syntax

SetAcDbObject() As Object


AcSmAcDbViewReference.SetAcDbObject

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.SetAcDbObject Method

Sets and modifies all properties of the object reference specified by the AcDbObject pointer.

This method is recommended for initializing an AcSmAcDbObjectReference object.

Syntax

SetAcDbObject() As Object


AcSmNamedAcDbObjectReference.SetAcDbObject

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.SetAcDbObject Method

Sets and modifies all properties of the object reference specified by the AcDbObject pointer.

This method is recommended for initializing an AcSmAcDbObjectReference object.

Syntax

SetAcDbObject() As Object


AcSmSheetSet.SetAltPageSetups

Up a level to AcSmSheetSet
AcSmSheetSet.SetAltPageSetups Method

Sets the IAcSmFileReference component that references the template containing alternative page setups.

Syntax

SetAltPageSetups(

pDwtRef As IAcSmFileReference) As Object

pDwtRef Sets the IAcSmFileReference component that references a file containing alternative page setups


AcSmSheet.SetCategory

Up a level to AcSmSheet
AcSmSheet.SetCategory Method

Sets the Category property. Returns S_OK if successful.

Syntax

SetCategory(

newVal As BSTR) As HRESULT

newVal Input string to set the Category property


AcSmSheetView.SetCategory

Up a level to AcSmSheetView
AcSmSheetView.SetCategory Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetCategory(

pViewCat As IAcSmViewCategory) As Object

pViewCat View category


AcSmSheetSet.SetDefAltPageSetup

Up a level to AcSmSheetSet
AcSmSheetSet.SetDefAltPageSetup Method

Sets the IAcSmNamedAcDbObjectReference component that references the default page setup within the template containing the alternative page setups.

Syntax

SetDefAltPageSetup(

pAltPageSetup As IAcSmNamedAcDbObjectReference) As Object

pAltPageSetup Input object that references the default page setup within the template containing the alternative page setups


AcSmPublishOptions.SetDefaultOutputdir

Up a level to AcSmPublishOptions
AcSmPublishOptions.SetDefaultOutputdir Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetDefaultOutputdir(

pValue As String) As Object

pValue Input value


AcSmSheetSet.SetDefDwtLayout

Up a level to AcSmSheetSet
AcSmSheetSet.SetDefDwtLayout Method

Sets the AcSmAcDbLayoutReference that points to the AcDbLayout to be used as a template for new sheet creation.

Syntax

SetDefDwtLayout(

pLayoutRef As IAcSmAcDbLayoutReference) As Object

pLayoutRef Input reference to layout


AcSmSubset.SetDefDwtLayout

Up a level to AcSmSubset
AcSmSubset.SetDefDwtLayout Method

Sets the AcSmAcDbLayoutReference that points to the layout used as a template for new sheets.

Syntax

SetDefDwtLayout(

pLayoutRef As IAcSmAcDbLayoutReference) As Object

pLayoutRef Input AcSmAcDbLayoutReference that points to the layout used as a template for new sheets


AcSmSheetSet.SetDefLabelBlk

Up a level to AcSmSheetSet
AcSmSheetSet.SetDefLabelBlk Method

Sets the AcSmAcDbBlockRecordReference component that references the label block definition for the sheet set.

Syntax

SetDefLabelBlk(

pLabelBlkRef As IAcSmAcDbBlockRecordReference) As Object

pLabelBlkRef Input AcSmAcDbBlockRecordReference component that references the block, as a file or named block, for the sheet set


AcSmCalloutBlockReferences.SetDesc

Up a level to AcSmCalloutBlockReferences
AcSmCalloutBlockReferences.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(

desc As String) As Object

desc Input string containing the text to set as the description


AcSmCalloutBlocks.SetDesc

Up a level to AcSmCalloutBlocks
AcSmCalloutBlocks.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(

desc As String) As Object

desc Input string containing the text to set as the description


AcSmDatabase.SetDesc

Up a level to AcSmDatabase
AcSmDatabase.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(

desc As String) As Object

desc Input string containing the text to set as the description


AcSmResources.SetDesc

Up a level to AcSmResources
AcSmResources.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(

desc As String) As Object

desc Input string containing the text to set as the description


AcSmSheet.SetDesc

Up a level to AcSmSheet
AcSmSheet.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(

desc As String) As Object

desc Input string containing the text to set as the description


AcSmSheetSelSet.SetDesc

Up a level to AcSmSheetSelSet
AcSmSheetSelSet.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(

desc As String) As Object

desc Input string containing the text to set as the description


AcSmSheetSelSets.SetDesc

Up a level to AcSmSheetSelSets
AcSmSheetSelSets.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(

desc As String) As Object

desc Input string containing the text to set as the description


AcSmSheetSet.SetDesc

Up a level to AcSmSheetSet
AcSmSheetSet.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(

desc As String) As Object

desc Input string containing the text to set as the description


AcSmSheetView.SetDesc

Up a level to AcSmSheetView
AcSmSheetView.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(

desc As String) As Object

desc Input string containing the text to set as the description


AcSmSheetViews.SetDesc

Up a level to AcSmSheetViews
AcSmSheetViews.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(

desc As String) As Object

desc Input string containing the text to set as the description


AcSmSubset.SetDesc

Up a level to AcSmSubset
AcSmSubset.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(

desc As String) As Object

desc Input string containing the text to set as the description


AcSmViewCategories.SetDesc

Up a level to AcSmViewCategories
AcSmViewCategories.SetDesc Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetDesc(

desc As String) As Object

desc Input string containing the text to set as the description


AcSmViewCategory.SetDesc

Up a level to AcSmViewCategory
AcSmViewCategory.SetDesc Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetDesc(

desc As String) As Object

desc Input string containing the text to set as the description


IAcSmComponent.SetDesc

Up a level to IAcSmComponent
IAcSmComponent.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(

desc As String) As Object

desc Input string containing the text to set as the description


AcSmSheet.SetDoNotPlot

Up a level to AcSmSheet
AcSmSheet.SetDoNotPlot Method

Sets a flag indicating whether a sheet should be skipped during plotting and publishing.

Syntax

SetDoNotPlot(

doNotPlot As Boolean) As Object

doNotPlot Input Boolean indicating whether a sheet should be skipped during plotting and publishing


AcSmPublishOptions.SetDwfType

Up a level to AcSmPublishOptions
AcSmPublishOptions.SetDwfType Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetDwfType(

value As Boolean) As Object

value Input value


AcSmAcDbBlockRecordReference.SetFileName

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.SetFileName Method

Sets the file name that this object will reference.

Syntax

SetFileName(

pValue As String) As Object

pValue Input file name


AcSmAcDbLayoutReference.SetFileName

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.SetFileName Method

Sets the file name that this object will reference.

Syntax

SetFileName(

pValue As String) As Object

pValue Input file name


AcSmAcDbObjectReference.SetFileName

Up a level to AcSmAcDbObjectReference
AcSmAcDbObjectReference.SetFileName Method

Sets the file name that this object will reference.

Syntax

SetFileName(

pValue As String) As Object

pValue Input string indicating file name


AcSmAcDbViewReference.SetFileName

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.SetFileName Method

Sets the file name that this object will reference.

Syntax

SetFileName(

pValue As String) As Object

pValue Input file name


AcSmDatabase.SetFileName

Up a level to AcSmDatabase
AcSmDatabase.SetFileName Method

Set the file name for this database. You can set the file name only once.

Syntax

SetFileName(

newVal As String) As Object

newVal Input file name for the database


AcSmFileReference.SetFileName

Up a level to AcSmFileReference
AcSmFileReference.SetFileName Method

Sets the file name that this object will reference.

A fully qualified file name should be used.

Syntax

SetFileName(

pValue As String) As Object

pValue Input string indicating a file name and path to be referenced


AcSmNamedAcDbObjectReference.SetFileName

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.SetFileName Method

Sets the file name that this object will reference.

Syntax

SetFileName(

pValue As String) As Object

pValue Input file name


AcSmCustomPropertyValue.SetFlags

Up a level to AcSmCustomPropertyValue
AcSmCustomPropertyValue.SetFlags Method

Sets a combination of PropertyFlags enum values associated with the custom property.

Syntax

SetFlags(

value As __MIDL___MIDL_itf_AcSmComponents_0268_0001) As Object

value Input property flags enumeration associated with the custom property


AcSmPublishOptions.SetIncludePlotStamp

Up a level to AcSmPublishOptions
AcSmPublishOptions.SetIncludePlotStamp Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetIncludePlotStamp() As Boolean


AcSmSheet.SetIssuePurpose

Up a level to AcSmSheet
AcSmSheet.SetIssuePurpose Method

Sets the IssuePurpose property. Returns S_OK if successful.

Syntax

SetIssuePurpose(

newVal As BSTR) As HRESULT

newVal Input string to set the IssuePurpose property


AcSmDatabase.SetIsTemporary

Up a level to AcSmDatabase
AcSmDatabase.SetIsTemporary Method

Marks the database as non-persisted.

Syntax

SetIsTemporary() As Object


AcSmPublishOptions.SetLayerInfo

Up a level to AcSmPublishOptions
AcSmPublishOptions.SetLayerInfo Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetLayerInfo(

value As Boolean) As Object

value Input value


AcSmSheet.SetLayout

Up a level to AcSmSheet
AcSmSheet.SetLayout Method

Sets the AcSmAcDbLayoutReference object, which references the drawing and layout associated with the sheet component.

Syntax

SetLayout(

pLayoutRef As IAcSmAcDbLayoutReference) As Object

pLayoutRef Input AcSmAcDbLayoutReference indicating the drawing and layout associated with the sheet component


AcSmAcDbBlockRecordReference.SetName

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.SetName Method

Sets the name of the referenced object.

Syntax

SetName(

name As String) As Object

name Input string containing the name of a symbol table record or dictionary entry


AcSmAcDbLayoutReference.SetName

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.SetName Method

Sets the name of the referenced object.

Syntax

SetName(

name As String) As Object

name Input string containing the name of a symbol table record or dictionary entry


AcSmAcDbViewReference.SetName

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.SetName Method

Sets the name of the referenced object.

Syntax

SetName(

name As String) As Object

name Input string containing the name of a symbol table record or dictionary entry


AcSmCalloutBlockReferences.SetName

Up a level to AcSmCalloutBlockReferences
AcSmCalloutBlockReferences.SetName Method

Sets the Name property of the component.

Syntax

SetName(

name As String) As Object

name Input string containing Name value


AcSmCalloutBlocks.SetName

Up a level to AcSmCalloutBlocks
AcSmCalloutBlocks.SetName Method

Sets the Name property of the component.

Syntax

SetName(

name As String) As Object

name Input string containing Name value


AcSmDatabase.SetName

Up a level to AcSmDatabase
AcSmDatabase.SetName Method

Sets the Name property of the component.

Syntax

SetName(

name As String) As Object

name Input string containing Name value


AcSmNamedAcDbObjectReference.SetName

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.SetName Method

Sets the name of the referenced object.

Syntax

SetName(

name As String) As Object

name Input string containing the name of a symbol table record or dictionary entry


AcSmResources.SetName

Up a level to AcSmResources
AcSmResources.SetName Method

Sets the Name property of the component.

Syntax

SetName(

name As String) As Object

name Input string containing Name value


AcSmSheet.SetName

Up a level to AcSmSheet
AcSmSheet.SetName Method

Sets the Name property of the component.

Syntax

SetName(

name As String) As Object

name Input string containing Name value


AcSmSheetSelSet.SetName

Up a level to AcSmSheetSelSet
AcSmSheetSelSet.SetName Method

Sets the Name property of the component.

Syntax

SetName(

name As String) As Object

name Input string containing Name value


AcSmSheetSelSets.SetName

Up a level to AcSmSheetSelSets
AcSmSheetSelSets.SetName Method

Sets the Name property of the component.

Syntax

SetName(

name As String) As Object

name Input string containing Name value


AcSmSheetSet.SetName

Up a level to AcSmSheetSet
AcSmSheetSet.SetName Method

Returns S_FALSE without setting the Name property of the component. The Name property of the component should be changed at the component level.

Syntax

SetName(

name As String) As Object

name Input string containing Name value


AcSmSheetView.SetName

Up a level to AcSmSheetView
AcSmSheetView.SetName Method

Sets the Name property of the component.

Syntax

SetName(

name As String) As Object

name Input string containing Name value


AcSmSheetViews.SetName

Up a level to AcSmSheetViews
AcSmSheetViews.SetName Method

Sets the Name property of the component.

Syntax

SetName(

name As String) As Object

name Input string containing Name value


AcSmSubset.SetName

Up a level to AcSmSubset
AcSmSubset.SetName Method

Sets the Name property of the component.

Syntax

SetName(

name As String) As Object

name Input string containing Name value


AcSmViewCategories.SetName

Up a level to AcSmViewCategories
AcSmViewCategories.SetName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetName(

name As String) As Object

name Input string containing Name value


AcSmViewCategory.SetName

Up a level to AcSmViewCategory
AcSmViewCategory.SetName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetName(

name As String) As Object

name Input string containing Name value


IAcSmComponent.SetName

Up a level to IAcSmComponent
IAcSmComponent.SetName Method

Sets the Name property of the component.

Syntax

SetName(

name As String) As Object

name Input string containing Name value


AcSmSheetView.SetNamedView

Up a level to AcSmSheetView
AcSmSheetView.SetNamedView Method

Sets the AcSmAcDbViewReference that points to the named AcDbView object on the sheet referenced by this sheet view component.

Syntax

SetNamedView(

pViewRef As IAcSmAcDbViewReference) As Object

pViewRef Input AcSmAcDbViewReference that provides a drawing name, view name, and handle for a view


AcSmSheetSet.SetNewSheetLocation

Up a level to AcSmSheetSet
AcSmSheetSet.SetNewSheetLocation Method

Sets the IAcSmFileReference that points to the location in the file system where new sheets are created.

Syntax

SetNewSheetLocation(

pFileRef As IAcSmFileReference) As Object

pFileRef Input pointer to location to be referenced


AcSmSubset.SetNewSheetLocation

Up a level to AcSmSubset
AcSmSubset.SetNewSheetLocation Method

Sets the IAcSmFileReference that points to the location in the file system where new sheets are created.

Syntax

SetNewSheetLocation(

pFileRef As IAcSmFileReference) As Object

pFileRef Input IAcSmFileReference pointing to the location in the file system where new sheets are created


AcSmSheet.SetNumber

Up a level to AcSmSheet
AcSmSheet.SetNumber Method

Sets the Number property of the sheet.

Syntax

SetNumber(

num As String) As Object

num Input string indicating the sheet number


AcSmSheetView.SetNumber

Up a level to AcSmSheetView
AcSmSheetView.SetNumber Method

Sets the Number property of the sheet view.

Syntax

SetNumber(

num As String) As Object

num Input Number property of the sheet view


AcSmPublishOptions.SetOutputFileName

Up a level to AcSmPublishOptions
AcSmPublishOptions.SetOutputFileName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetOutputFileName(

value As IAcSmFileReference) As Object

value Input value


AcSmAcDbBlockRecordReference.SetOwner

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmAcDbLayoutReference.SetOwner

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmAcDbObjectReference.SetOwner

Up a level to AcSmAcDbObjectReference
AcSmAcDbObjectReference.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmAcDbViewReference.SetOwner

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmCalloutBlockReferences.SetOwner

Up a level to AcSmCalloutBlockReferences
AcSmCalloutBlockReferences.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmCalloutBlocks.SetOwner

Up a level to AcSmCalloutBlocks
AcSmCalloutBlocks.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmCustomPropertyBag.SetOwner

Up a level to AcSmCustomPropertyBag
AcSmCustomPropertyBag.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmCustomPropertyValue.SetOwner

Up a level to AcSmCustomPropertyValue
AcSmCustomPropertyValue.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmDatabase.SetOwner

Up a level to AcSmDatabase
AcSmDatabase.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmFileReference.SetOwner

Up a level to AcSmFileReference
AcSmFileReference.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmNamedAcDbObjectReference.SetOwner

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmObjectReference.SetOwner

Up a level to AcSmObjectReference
AcSmObjectReference.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmPersistProxy.SetOwner

Up a level to AcSmPersistProxy
AcSmPersistProxy.SetOwner Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmPublishOptions.SetOwner

Up a level to AcSmPublishOptions
AcSmPublishOptions.SetOwner Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmResources.SetOwner

Up a level to AcSmResources
AcSmResources.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmSheet.SetOwner

Up a level to AcSmSheet
AcSmSheet.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmSheetSelSet.SetOwner

Up a level to AcSmSheetSelSet
AcSmSheetSelSet.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmSheetSelSets.SetOwner

Up a level to AcSmSheetSelSets
AcSmSheetSelSets.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmSheetSet.SetOwner

Up a level to AcSmSheetSet
AcSmSheetSet.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmSheetView.SetOwner

Up a level to AcSmSheetView
AcSmSheetView.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmSheetViews.SetOwner

Up a level to AcSmSheetViews
AcSmSheetViews.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmSubset.SetOwner

Up a level to AcSmSubset
AcSmSubset.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmViewCategories.SetOwner

Up a level to AcSmViewCategories
AcSmViewCategories.SetOwner Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmViewCategory.SetOwner

Up a level to AcSmViewCategory
AcSmViewCategory.SetOwner Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


IAcSmComponent.SetOwner

Up a level to IAcSmComponent
IAcSmComponent.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


IAcSmPersist.SetOwner

Up a level to IAcSmPersist
IAcSmPersist.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(

pOwner As IAcSmPersist) As Object

pOwner Input pointer to the owner of the object


AcSmAcDbBlockRecordReference.SetOwnerAcDbHandle

Up a level to AcSmAcDbBlockRecordReference
AcSmAcDbBlockRecordReference.SetOwnerAcDbHandle Method

Sets the AcDbHandle of the owning AcDbObject.

Syntax

SetOwnerAcDbHandle(

handle As String) As Object

handle Input string that indicates the AcDbHandle to set


AcSmAcDbLayoutReference.SetOwnerAcDbHandle

Up a level to AcSmAcDbLayoutReference
AcSmAcDbLayoutReference.SetOwnerAcDbHandle Method

Sets the AcDbHandle of the owning AcDbObject.

Syntax

SetOwnerAcDbHandle(

handle As String) As Object

handle Input string that indicates the AcDbHandle to set


AcSmAcDbViewReference.SetOwnerAcDbHandle

Up a level to AcSmAcDbViewReference
AcSmAcDbViewReference.SetOwnerAcDbHandle Method

Sets the AcDbHandle of the owning AcDbObject.

Syntax

SetOwnerAcDbHandle(

handle As String) As Object

handle Input string that indicates the AcDbHandle to set


AcSmNamedAcDbObjectReference.SetOwnerAcDbHandle

Up a level to AcSmNamedAcDbObjectReference
AcSmNamedAcDbObjectReference.SetOwnerAcDbHandle Method

Sets the AcDbHandle of the owning AcDbObject.

Syntax

SetOwnerAcDbHandle(

handle As String) As Object

handle Input string that indicates the AcDbHandle to set


AcSmPublishOptions.SetPassword

Up a level to AcSmPublishOptions
AcSmPublishOptions.SetPassword Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetPassword() As Object


AcSmSheetSet.SetProjectMilestone

Up a level to AcSmSheetSet
AcSmSheetSet.SetProjectMilestone Method

Sets the ProjectMilestone property. Returns S_OK if successful.

Syntax

SetProjectMilestone(

newVal As BSTR) As HRESULT

newVal Input string to set the ProjectMilestone property


AcSmSheetSet.SetProjectName

Up a level to AcSmSheetSet
AcSmSheetSet.SetProjectName Method

Sets the project name associated with this sheet set. Returns S_OK if successful.

Syntax

SetProjectName(

newVal As BSTR) As HRESULT

newVal Input string to set the ProjectName property


AcSmSheetSet.SetProjectNumber

Up a level to AcSmSheetSet
AcSmSheetSet.SetProjectNumber Method

Sets the project number associated with this sheet set. Returns S_OK if successful.

Syntax

SetProjectNumber(

newVal As BSTR) As HRESULT

newVal Input string to set the ProjectNumber property


AcSmSheetSet.SetProjectPhase

Up a level to AcSmSheetSet
AcSmSheetSet.SetProjectPhase Method

Sets the ProjectPhase property. Returns S_OK if successful.

Syntax

SetProjectPhase(

newVal As BSTR) As HRESULT

newVal Input string to set the ProjectPhase property


AcSmSheetSet.SetPromptForDwgName

Up a level to AcSmSheetSet
AcSmSheetSet.SetPromptForDwgName Method

Sets the flag indicating whether the user interface should prompt for the name of a new drawing.

Syntax

SetPromptForDwgName(

askForName As Boolean) As Object

askForName Input Boolean indicating whether the user interface should prompt for the name of a new drawing


AcSmSheetSet.SetPromptForDwt

Up a level to AcSmSheetSet
AcSmSheetSet.SetPromptForDwt Method

Sets the Boolean flag that indicates whether the application should prompt for a DWT file.

Syntax

SetPromptForDwt(

askForDwt As Boolean) As Object

askForDwt Input flag indicating whether the application should prompt for a DWT file


AcSmSubset.SetPromptForDwt

Up a level to AcSmSubset
AcSmSubset.SetPromptForDwt Method

Sets a Boolean flag indicating if the application should prompt for a DWT file.

Syntax

SetPromptForDwt(

askForDwt As Boolean) As Object

askForDwt Input Boolean flag indicating if the application should prompt for a DWT file


AcSmPublishOptions.SetPromptForName

Up a level to AcSmPublishOptions
AcSmPublishOptions.SetPromptForName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetPromptForName(

value As Boolean) As Object

value Input value


AcSmPublishOptions.SetPromptForPassword

Up a level to AcSmPublishOptions
AcSmPublishOptions.SetPromptForPassword Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetPromptForPassword(

value As Boolean) As Object

value Input Boolean indicating whether to prompt for password


AcSmCustomPropertyBag.SetProperty

Up a level to AcSmCustomPropertyBag
AcSmCustomPropertyBag.SetProperty Method

Sets the IAcSmCustomPropertyValue specified with the Name parameter.

You can remove a property by specifying a null IAcSmCustomPropertyValue value.

Syntax

SetProperty(

name As String,

value As IAcSmCustomPropertyValue) As Object

name | Input string containing the Name value of a property
value | Input pointer to a properly initialized IAcSmCustomPropertyValue


AcSmObjectReference.SetReferencedObject

Up a level to AcSmObjectReference
AcSmObjectReference.SetReferencedObject Method

Sets the IAcSmPersist object to reference.

Syntax

SetReferencedObject(

pObject As IAcSmPersist) As Object

pObject Input pointer to the IAcSmPersist object to reference


AcSmObjectReference.SetReferenceFlags

Up a level to AcSmObjectReference
AcSmObjectReference.SetReferenceFlags Method

Sets the reference flags to hard referencing or soft referencing.

Syntax

SetReferenceFlags(

value As AcSmObjectReferenceFlags) As Object

value Input flag for hard referencing or for soft referencing


AcSmSheet.SetRevisionDate

Up a level to AcSmSheet
AcSmSheet.SetRevisionDate Method

Sets the RevisionDate property. Returns S_OK if successful.

Syntax

SetRevisionDate(

newVal As BSTR) As HRESULT

newVal Input string to set the RevisionDate property


AcSmSheet.SetRevisionNumber

Up a level to AcSmSheet
AcSmSheet.SetRevisionNumber Method

Sets the RevisionNumber property. Returns S_OK if successful.

Syntax

SetRevisionNumber(

newVal As BSTR) As HRESULT

newVal Input string to set the RevisionNumber property


AcSmSheet.SetTitle

Up a level to AcSmSheet
AcSmSheet.SetTitle Method

Sets the title of the sheet.

Syntax

SetTitle(

title As String) As Object

title Input string containing the title of the sheet


AcSmSheetView.SetTitle

Up a level to AcSmSheetView
AcSmSheetView.SetTitle Method

Sets the Title property of the sheet view.

Syntax

SetTitle(

title As String) As Object

title Input Title property of the sheet view


AcSmPersistProxy.SetTypeName

Up a level to AcSmPersistProxy
AcSmPersistProxy.SetTypeName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetTypeName(

value As String) As Object

value Input value


AcSmPublishOptions.SetUnrecognizedData

Up a level to AcSmPublishOptions
AcSmPublishOptions.SetUnrecognizedData Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetUnrecognizedData() As Object


AcSmPublishOptions.SetUnrecognizedSections

Up a level to AcSmPublishOptions
AcSmPublishOptions.SetUnrecognizedSections Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetUnrecognizedSections() As Object


AcSmPublishOptions.SetUsePassword

Up a level to AcSmPublishOptions
AcSmPublishOptions.SetUsePassword Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetUsePassword(

value As Boolean) As Object

value Input value


AcSmCustomPropertyValue.SetValue

Up a level to AcSmCustomPropertyValue
AcSmCustomPropertyValue.SetValue Method

Sets the variant value associated with the custom property.

Syntax

SetValue(

value As Variant) As Object

value Input variant value to associate with the custom property


AcSmSheetSet.Sync

Up a level to AcSmSheetSet
AcSmSheetSet.Sync Method

Updates the sheet view components in the sheet set of the provided AcadDatabase object.

Syntax

Sync(

pXDb As IAcadDatabase) As Object

pXDb Input IAcadDatabase object


AcSmSheetViews.Sync

Up a level to AcSmSheetViews
AcSmSheetViews.Sync Method

Updates the sheet view components in the collection according to the provided AcSmAcDbLayoutReference and IAcadDatabase.

Syntax

Sync(

pLayout As IAcSmAcDbLayoutReference,

pXDb As IAcadDatabase) As Object

pLayout | Input AcSmAcDbLayoutReference to update
pXDb | Input IAcadDatabase to use for the update


AcSmDatabase.UnlockDb

Up a level to AcSmDatabase
AcSmDatabase.UnlockDb Method

Unlocks the database.

Use the bCommit parameter to specify if changes should be saved to disk.

Syntax

UnlockDb(

pObject As Object,

bCommit As Boolean = True) As Object

pObject | Input owner of the database lock
bCommit | Input Boolean specifying True if changes should be saved to disk


AcSmDatabase.Unregister

Up a level to AcSmDatabase
AcSmDatabase.Unregister Method

Unregisters a callback notification handler that was previously registered.

Syntax

Unregister(

cookie As Long) As Object

cookie Input long indicating the cookie value for the Register call


AcSmSheetSet.Unregister

Up a level to AcSmSheetSet
AcSmSheetSet.Unregister Method

Unregisters a callback notification handler that was previously registered.

Syntax

Unregister(

cookie As Long) As Object

cookie Input cookie value received in the registration call


AcSmSheetSetMgr.Unregister

Up a level to AcSmSheetSetMgr
AcSmSheetSetMgr.Unregister Method

Unregisters a callback notification handler that was previously registered.

Syntax

Unregister(

cookie As Long) As Object

cookie Input cookie value received in the Register call


AcSmDatabase.UpdateInMemoryDwgHints

Up a level to AcSmDatabase
AcSmDatabase.UpdateInMemoryDwgHints Method

Updates the hints in the open drawings referenced by this database.

Syntax

UpdateInMemoryDwgHints() As Object


AcSmSheetSet.UpdateInMemoryDwgHints

Up a level to AcSmSheetSet
AcSmSheetSet.UpdateInMemoryDwgHints Method

Updates the hints in the open drawings referenced in the subset.

Syntax

UpdateInMemoryDwgHints() As Object


AcSmSubset.UpdateInMemoryDwgHints

Up a level to AcSmSubset
AcSmSubset.UpdateInMemoryDwgHints Method

Updates the hints in the open drawings referenced in the subset.

Syntax

UpdateInMemoryDwgHints() As Object


AcSmDSTFiler.WriteObject

Up a level to AcSmDSTFiler
AcSmDSTFiler.WriteObject Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

WriteObject(

pObj As IAcSmPersist) As Object

pObj Input pointer to the IAcSmPersist object to write


AcSmDSTFiler.WriteProperty

Up a level to AcSmDSTFiler
AcSmDSTFiler.WriteProperty Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

WriteProperty(

pPropname As String,

pVal As Variant) As Object

pPropname | Input string indicating the name of the property to be written
pVal | Input variant indicating the value of the property to be written


AcSmDSTFiler.WriteRawData

Up a level to AcSmDSTFiler
AcSmDSTFiler.WriteRawData Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

WriteRawData(

p As Byte,

count As Long) As Object

p | Input pointer to the raw data buffer
count | Input pointer to the size of the raw data buffer


AcSmAcDbBlockRecordReference

Up a level to
AcSmAcDbBlockRecordReference Object

Refers to a block record in a drawing file.

Methods, Properties and Events

Methods
Clear
GetAcDbHandle
GetAcSmAcDbDatabase
GetDatabase
GetDirectlyOwnedObjects
GetFileName
GetIsDirty
GetName
GetObjectId
GetOwner
GetOwnerAcDbHandle
GetTypeName
InitNew
Load
ResolveAcDbObject
ResolveFileName
Save
SetAcDbHandle
SetAcDbObject
SetFileName
SetName
SetOwner
SetOwnerAcDbHandle


AcSmAcDbDatabase

Up a level to
AcSmAcDbDatabase Object

This API was designed for internal use and has not been thoroughly tested.

Methods, Properties and Events

Methods
GetAcDbDatabase
GetIAcadDatabase


AcSmAcDbLayoutReference

Up a level to
AcSmAcDbLayoutReference Object

Refers to a layout in a drawing file.

Methods, Properties and Events

Methods
Clear
GetAcDbHandle
GetAcSmAcDbDatabase
GetDatabase
GetDirectlyOwnedObjects
GetFileName
GetIsDirty
GetName
GetObjectId
GetOwner
GetOwnerAcDbHandle
GetTypeName
InitNew
Load
ResolveAcDbObject
ResolveFileName
Save
SetAcDbHandle
SetAcDbObject
SetFileName
SetName
SetOwner
SetOwnerAcDbHandle


AcSmAcDbObjectReference

Up a level to
AcSmAcDbObjectReference Object

The AcDbObject reference component.

To properly initialize an IAcSmAcDbObjectReference in order to reference a stored AcDbObject, use the SetAcDbObject method. This method initializes the NamedAcDbObjectReference, so there is no need to use the SetAcDbHandle method, SetFileName method, or SetName method.

To find a referenced object in an AcDbDatabase, use the ResolveAcDbObject method. For example, to find a layout in order to retrieve its properties, use the ResolveAcDbObject method.

Methods, Properties and Events

Methods
Clear
GetAcDbHandle
GetAcSmAcDbDatabase
GetDatabase
GetDirectlyOwnedObjects
GetFileName
GetIsDirty
GetObjectId
GetOwner
GetTypeName
InitNew
Load
ResolveAcDbObject
ResolveFileName
Save
SetAcDbHandle
SetAcDbObject
SetFileName
SetOwner


AcSmAcDbViewReference

Up a level to
AcSmAcDbViewReference Object

Refers to a view in a drawing file.

Methods, Properties and Events

Methods
Clear
GetAcDbHandle
GetAcSmAcDbDatabase
GetDatabase
GetDirectlyOwnedObjects
GetFileName
GetIsDirty
GetName
GetObjectId
GetOwner
GetOwnerAcDbHandle
GetTypeName
InitNew
Load
ResolveAcDbObject
ResolveFileName
Save
SetAcDbHandle
SetAcDbObject
SetFileName
SetName
SetOwner
SetOwnerAcDbHandle


AcSmCalloutBlockReferences

Up a level to
AcSmCalloutBlockReferences Object

Callout block references collection.

Methods, Properties and Events

Methods
Add
Clear
GetCustomPropertyBag
GetDatabase
GetDesc
GetDirectlyOwnedObjects
GetEnumerator
GetIsDirty
GetName
GetObjectId
GetOwner
GetTypeName
InitNew
Load
Remove
Save
SetDesc
SetName
SetOwner


AcSmCalloutBlocks

Up a level to
AcSmCalloutBlocks Object

Callout blocks collection that contains IAcSmNamedAcDbObjectReference objects.

Methods, Properties and Events

Methods
Add
Clear
GetCustomPropertyBag
GetDatabase
GetDesc
GetDirectlyOwnedObjects
GetEnumerator
GetIsDirty
GetName
GetObjectId
GetOwner
GetTypeName
InitNew
Load
Remove
Save
SetDesc
SetName
SetOwner


AcSmCustomPropertyBag

Up a level to
AcSmCustomPropertyBag Object

Custom property bag component, which stores custom properties. Every component that derives from IAcSmComponent has a GetCustomPropertyBag method. This method returns the property bag of the component.

Methods, Properties and Events

Methods
Clear
GetDatabase
GetDirectlyOwnedObjects
GetIsDirty
GetObjectId
GetOwner
GetProperty
GetPropertyEnumerator
GetTypeName
InitNew
Load
Save
SetOwner
SetProperty


AcSmCustomPropertyValue

Up a level to
AcSmCustomPropertyValue Object

Custom property value object.

Methods, Properties and Events

Methods
Clear
GetDatabase
GetDirectlyOwnedObjects
GetFlags
GetIsDirty
GetObjectId
GetOwner
GetTypeName
GetValue
InitNew
Load
Save
SetFlags
SetOwner
SetValue


AcSmDatabase

Up a level to
AcSmDatabase Object

Database component.

Methods, Properties and Events

Methods
Clear
FindObject
GetCustomPropertyBag
GetDatabase
GetDbVersion
GetDesc
GetDirectlyOwnedObjects
GetEnumerator
GetFileName
GetIsDirty
GetIsTemporary
GetLockOwnerInfo
GetLockStatus
GetName
GetNewObjectId
GetObjectId
GetOwner
GetSheetSet
GetTemplateDstFileName
GetTypeName
InitNew
Load
LoadFromFile
LockDb
NotifyRegisteredEventHandlers
Register
RegisterOwner
Save
SetDesc
SetFileName
SetIsTemporary
SetName
SetOwner
UnlockDb
Unregister
UpdateInMemoryDwgHints


AcSmDSTFiler

Up a level to
AcSmDSTFiler Object

This API was designed for internal use and has not been thoroughly tested.

Methods, Properties and Events

Methods
Close
GetCurrentObject
GetCurrentObjectHeaderInfo
GetDatabase
GetRevisionNumber
Init
PopCurrentReadObject
PopCurrentWriteObject
PushCurrentReadObject
PushCurrentWriteObject
ReadObject
ReadProperty
ReadRawData
WriteObject
WriteProperty
WriteRawData


AcSmEvent

Up a level to
AcSmEvent Object

Contains events in Sheet Set Manager objects.

Methods, Properties and Events

Properties
ACSM_DATABASE_CHANGED
ACSM_DATABASE_CREATED
ACSM_DATABASE_IS_CLOSING
ACSM_DATABASE_LOAD_BEGIN
ACSM_DATABASE_LOAD_COMPLETE
ACSM_DATABASE_LOAD_FAILED
ACSM_DATABASE_LOCKED
ACSM_DATABASE_OPENED
ACSM_DATABASE_UNLOCKED
CALLOUT_BLOCK_ADDED
CALLOUT_BLOCK_DELETED
MODEL_RESOURCE_ADDED
MODEL_RESOURCE_DELETED
SHEET_ADDED
SHEET_DELETED
SHEET_SELECTION_SET_CREATED
SHEET_SELECTION_SET_DELETED
SHEET_SUBSET_CREATED
SHEET_SUBSET_DELETED
SHEET_VIEW_CATEGORY_CREATED
SHEET_VIEW_CATEGORY_DELETED
SHEET_VIEW_CREATED
SHEET_VIEW_DELETED
SHEETS_RENUMBERED


AcSmFileReference

Up a level to
AcSmFileReference Object

File reference component.

Use the ResolveFileName method to retrieve the fully qualified path to a resolved file name.

Methods, Properties and Events

Methods
Clear
GetDatabase
GetDirectlyOwnedObjects
GetFileName
GetIsDirty
GetObjectId
GetOwner
GetTypeName
InitNew
Load
ResolveFileName
Save
SetFileName
SetOwner


AcSmNamedAcDbObjectReference

Up a level to
AcSmNamedAcDbObjectReference Object

Stores a named AcDbObject, such as a symbol table record or a dictionary entry. The name and handle of the object are stored, so either one can be used to locate the object.

To reference a stored AcDbObject, use the SetAcDbObject method. This method initializes the NamedAcDbObjectReference, so there is no need to use the SetAcDbHandle method, SetFileName method, or SetName method.

To find the referenced object in an AcDbDatabase, use the ResolveAcDbObject method.

Methods, Properties and Events

Methods
Clear
GetAcDbHandle
GetAcSmAcDbDatabase
GetDatabase
GetDirectlyOwnedObjects
GetFileName
GetIsDirty
GetName
GetObjectId
GetOwner
GetOwnerAcDbHandle
GetTypeName
InitNew
Load
ResolveAcDbObject
ResolveFileName
Save
SetAcDbHandle
SetAcDbObject
SetFileName
SetName
SetOwner
SetOwnerAcDbHandle


AcSmObjectReference

Up a level to
AcSmObjectReference Object

Object reference component.

Methods, Properties and Events

Methods
Clear
GetDatabase
GetDirectlyOwnedObjects
GetIsDirty
GetObjectId
GetOwner
GetReferencedObject
GetReferenceFlags
GetTypeName
InitNew
Load
Save
SetOwner
SetReferencedObject
SetReferenceFlags


AcSmPersistProxy

Up a level to
AcSmPersistProxy Object

This API was designed for internal use and has not been thoroughly tested.

Methods, Properties and Events

Methods
Clear
GetDatabase
GetDirectlyOwnedObjects
GetIsDirty
GetObjectId
GetOwner
GetTypeName
InitNew
Load
Save
SetOwner
SetTypeName


AcSmPublishOptions

Up a level to
AcSmPublishOptions Object

This API was designed for internal use and has not been thoroughly tested.

Methods, Properties and Events

Methods
Clear
GetDatabase
GetDefaultOutputdir
GetDirectlyOwnedObjects
GetDwfType
GetIncludePlotStamp
GetIsDirty
GetLayerInfo
GetObjectId
GetOutputFileName
GetOwner
GetPassword
GetPromptForName
GetPromptForPassword
GetTypeName
GetUnrecognizedData
GetUnrecognizedSections
GetUsePassword
InitNew
Load
Save
SetDefaultOutputdir
SetDwfType
SetIncludePlotStamp
SetLayerInfo
SetOutputFileName
SetOwner
SetPassword
SetPromptForName
SetPromptForPassword
SetUnrecognizedData
SetUnrecognizedSections
SetUsePassword


AcSmResources

Up a level to
AcSmResources Object

Resources collection that contains IAcSmFileReference objects.

Methods, Properties and Events

Methods
Add
Clear
GetCustomPropertyBag
GetDatabase
GetDesc
GetDirectlyOwnedObjects
GetEnumerator
GetIsDirty
GetName
GetObjectId
GetOwner
GetTypeName
InitNew
Load
Remove
Save
SetDesc
SetName
SetOwner


AcSmSheet

Up a level to
AcSmSheet Object

Sheet component.

Methods, Properties and Events

Methods
Clear
GetCategory
GetCustomPropertyBag
GetDatabase
GetDesc
GetDirectlyOwnedObjects
GetDoNotPlot
GetIsDirty
GetIssuePurpose
GetLayout
GetName
GetNumber
GetObjectId
GetOwner
GetRevisionDate
GetRevisionNumber
GetSheetViews
GetTitle
GetTypeName
InitNew
Load
Save
SetCategory
SetDesc
SetDoNotPlot
SetIssuePurpose
SetLayout
SetName
SetNumber
SetOwner
SetRevisionDate
SetRevisionNumber
SetTitle


AcSmSheetSelSet

Up a level to
AcSmSheetSelSet Object

Selection set component.

Methods, Properties and Events

Methods
Add
Clear
GetCustomPropertyBag
GetDatabase
GetDesc
GetDirectlyOwnedObjects
GetEnumerator
GetIsDirty
GetName
GetObjectId
GetOwner
GetTypeName
InitNew
Load
Remove
Save
SetDesc
SetName
SetOwner


AcSmSheetSelSets

Up a level to
AcSmSheetSelSets Object

Selection sets collection.

Methods, Properties and Events

Methods
Add
Clear
GetCustomPropertyBag
GetDatabase
GetDesc
GetDirectlyOwnedObjects
GetEnumerator
GetIsDirty
GetName
GetObjectId
GetOwner
GetTypeName
InitNew
Load
Remove
Save
SetDesc
SetName
SetOwner


AcSmSheetSet

Up a level to
AcSmSheetSet Object

Sheet set component.

Methods, Properties and Events

Methods
AddNewSheet
Clear
CreateSubset
GetAltPageSetups
GetCalloutBlocks
GetCustomPropertyBag
GetDatabase
GetDefAltPageSetup
GetDefDwtLayout
GetDefLabelBlk
GetDesc
GetDirectlyOwnedObjects
GetIsDirty
GetName
GetNewSheetLocation
GetObjectId
GetOwner
GetProjectMilestone
GetProjectName
GetProjectNumber
GetProjectPhase
GetPromptForDwgName
GetPromptForDwt
GetPublishOptions
GetResources
GetSheetEnumerator
GetSheetSelSets
GetTypeName
GetViewCategories
ImportSheet
InitNew
InsertComponent
InsertComponentAfter
Load
NotifyRegisteredEventHandlers
Register
RemoveSheet
RemoveSubset
Save
SetAltPageSetups
SetDefAltPageSetup
SetDefDwtLayout
SetDefLabelBlk
SetDesc
SetName
SetNewSheetLocation
SetOwner
SetProjectMilestone
SetProjectName
SetProjectNumber
SetProjectPhase
SetPromptForDwgName
SetPromptForDwt
Sync
Unregister
UpdateInMemoryDwgHints


AcSmSheetSetMgr

Up a level to
AcSmSheetSetMgr Object

Sheet Set Manager object.

Methods, Properties and Events

Methods
Close
CloseAll
CreateDatabase
FindOpenDatabase
GetDatabaseEnumerator
GetParentSheetSet
OpenDatabase
Register
Unregister


AcSmSheetView

Up a level to
AcSmSheetView Object

Sheet view component.

Methods, Properties and Events

Methods
Clear
GetCategory
GetCustomPropertyBag
GetDatabase
GetDesc
GetDirectlyOwnedObjects
GetIsDirty
GetName
GetNamedView
GetNumber
GetObjectId
GetOwner
GetTitle
GetTypeName
InitNew
Load
Save
SetCategory
SetDesc
SetName
SetNamedView
SetNumber
SetOwner
SetTitle


AcSmSheetViews

Up a level to
AcSmSheetViews Object

Sheet views collection.

Methods, Properties and Events

Methods
Clear
GetCustomPropertyBag
GetDatabase
GetDesc
GetDirectlyOwnedObjects
GetEnumerator
GetIsDirty
GetName
GetObjectId
GetOwner
GetTypeName
InitNew
Load
Save
SetDesc
SetName
SetOwner
Sync


AcSmSubset

Up a level to
AcSmSubset Object

Subset component.

Methods, Properties and Events

Methods
AddNewSheet
Clear
CreateSubset
GetCustomPropertyBag
GetDatabase
GetDefDwtLayout
GetDesc
GetDirectlyOwnedObjects
GetIsDirty
GetName
GetNewSheetLocation
GetObjectId
GetOwner
GetPromptForDwt
GetSheetEnumerator
GetTypeName
ImportSheet
InitNew
InsertComponent
InsertComponentAfter
Load
NotifyRegisteredEventHandlers
RemoveSheet
RemoveSubset
Save
SetDefDwtLayout
SetDesc
SetName
SetNewSheetLocation
SetOwner
SetPromptForDwt
UpdateInMemoryDwgHints


AcSmViewCategories

Up a level to
AcSmViewCategories Object

This API was designed for internal use and has not been thoroughly tested.

Methods, Properties and Events

Methods
Clear
CreateViewCategory
GetCustomPropertyBag
GetDatabase
GetDefaultViewCategory
GetDesc
GetDirectlyOwnedObjects
GetEnumerator
GetIsDirty
GetName
GetObjectId
GetOwner
GetTypeName
InitNew
Load
RemoveViewCategory
Save
SetDesc
SetName
SetOwner


AcSmViewCategory

Up a level to
AcSmViewCategory Object

This API was designed for internal use and has not been thoroughly tested.

Methods, Properties and Events

Methods
Clear
GetCalloutBlocks
GetCustomPropertyBag
GetDatabase
GetDesc
GetDirectlyOwnedObjects
GetIsDirty
GetName
GetObjectId
GetOwner
GetSheetViewEnumerator
GetTypeName
InitNew
Load
Save
SetDesc
SetName
SetOwner


IAcSmComponent

Up a level to
IAcSmComponent Object

The IAcSmComponent interface defines the basic behavior of most Sheet Set Manager objects. The IAcSmComponent derives from the IAcSmPersist interface and includes all IAcSmPersist methods.

Methods, Properties and Events

Methods
Clear
GetCustomPropertyBag
GetDatabase
GetDesc
GetDirectlyOwnedObjects
GetIsDirty
GetName
GetObjectId
GetOwner
GetTypeName
InitNew
Load
Save
SetDesc
SetName
SetOwner


IAcSmEnumAcDbBlockRecordReference

Up a level to
IAcSmEnumAcDbBlockRecordReference Object

Object enumerator for AcSmAcDbBlockRecordReference.

Methods, Properties and Events

Methods
Next
Reset


IAcSmEnumComponent

Up a level to
IAcSmEnumComponent Object

Object enumerator for IAcSmComponent.

Methods, Properties and Events

Methods
Next
Reset


IAcSmEnumDatabase

Up a level to
IAcSmEnumDatabase Object

Object enumerator for IAcSmDatabase. For an example of how to use the Next method in VBA, see Reliably Access Sheet Set Components.

Methods, Properties and Events

Methods
Next
Reset


IAcSmEnumFileReference

Up a level to
IAcSmEnumFileReference Object

Object enumerator for IAcSmEnumFileReference.

Methods, Properties and Events

Methods
Next
Reset


IAcSmEnumPersist

Up a level to
IAcSmEnumPersist Object

Object enumerator for IAcSmEnumPersist.

Methods, Properties and Events

Methods
Next
Reset


IAcSmEnumProperty

Up a level to
IAcSmEnumProperty Object

Custom property enumerator interface.

Methods, Properties and Events

Methods
Next
Reset


IAcSmEnumSheetSelSet

Up a level to
IAcSmEnumSheetSelSet Object

Object enumerator for IAcSmEnumSheetSelSet. For an example of how to use the Next method in VBA, see Reliably Access Sheet Set Components.

Methods, Properties and Events

Methods
Next
Reset


IAcSmEnumSheetView

Up a level to
IAcSmEnumSheetView Object

Object enumerator for IAcSmEnumSheetView. For an example of how to use the Next method in VBA, see Reliably Access Sheet Set Components.

Methods, Properties and Events

Methods
Next
Reset


IAcSmEnumViewCategory

Up a level to
IAcSmEnumViewCategory Object

This API was designed for internal use and has not been thoroughly tested.

Methods, Properties and Events

Methods
Next
Reset


IAcSmEvents

Up a level to
IAcSmEvents Object

The callback interface used for event notifications.

Methods, Properties and Events

Methods
OnChanged


IAcSmObjectId

Up a level to
IAcSmObjectId Object

Unique identifier for each component.

Methods, Properties and Events

Methods
GetDatabase
GetHandle
GetOwner
GetPersistObject
IsEqual
IsValid


IAcSmPersist

Up a level to
IAcSmPersist Object

The base persistence interface used by an AcSmDatabase database.

Methods, Properties and Events

Methods
Clear
GetDatabase
GetDirectlyOwnedObjects
GetIsDirty
GetObjectId
GetOwner
GetTypeName
InitNew
Load
Save
SetOwner


PropertyFlags

Up a level to
PropertyFlags Object

Custom property flags. The flags are used with the GetFlags and SetFlags methods of the AcSmCustomPropertyValue object.

Methods, Properties and Events

Properties
CUSTOM_SHEET_PROP
EMPTY


AcSmEvent.ACSM_DATABASE_CHANGED

Up a level to AcSmEvent
AcSmEvent.ACSM_DATABASE_CHANGED Property

Event signifying that the database changed on disk. In response to this event, programs usually should use the LoadFromFile method of the AcSmDatabase object. The LoadFromFile method updates the database so it is the same as the database version on disk.

Syntax

ACSM_DATABASE_CHANGED() As Long


AcSmEvent.ACSM_DATABASE_CREATED

Up a level to AcSmEvent
AcSmEvent.ACSM_DATABASE_CREATED Property

Event signifying that a database was created.

Syntax

ACSM_DATABASE_CREATED() As Long


AcSmEvent.ACSM_DATABASE_IS_CLOSING

Up a level to AcSmEvent
AcSmEvent.ACSM_DATABASE_IS_CLOSING Property

Event signifying that an AcSmDatabase object is closing.

Syntax

ACSM_DATABASE_IS_CLOSING() As Long


AcSmEvent.ACSM_DATABASE_LOAD_BEGIN

Up a level to AcSmEvent
AcSmEvent.ACSM_DATABASE_LOAD_BEGIN Property

Event signifying that a database began loading in memory from disk.

Syntax

ACSM_DATABASE_LOAD_BEGIN() As Long


AcSmEvent.ACSM_DATABASE_LOAD_COMPLETE

Up a level to AcSmEvent
AcSmEvent.ACSM_DATABASE_LOAD_COMPLETE Property

Event signifying that a database completed a load into memory from disk.

Syntax

ACSM_DATABASE_LOAD_COMPLETE() As Long


AcSmEvent.ACSM_DATABASE_LOAD_FAILED

Up a level to AcSmEvent
AcSmEvent.ACSM_DATABASE_LOAD_FAILED Property

Event signifying that a database failed to load in memory from disk.

Syntax

ACSM_DATABASE_LOAD_FAILED() As Long


AcSmEvent.ACSM_DATABASE_LOCKED

Up a level to AcSmEvent
AcSmEvent.ACSM_DATABASE_LOCKED Property

Event signifying that the database is locked.

Syntax

ACSM_DATABASE_LOCKED() As Long


AcSmEvent.ACSM_DATABASE_OPENED

Up a level to AcSmEvent
AcSmEvent.ACSM_DATABASE_OPENED Property

Event signifying that the database is opened.

Syntax

ACSM_DATABASE_OPENED() As Long


AcSmEvent.ACSM_DATABASE_UNLOCKED

Up a level to AcSmEvent
AcSmEvent.ACSM_DATABASE_UNLOCKED Property

Event signifying that the database is unlocked.

Syntax

ACSM_DATABASE_UNLOCKED() As Long


AcSmEvent.CALLOUT_BLOCK_ADDED

Up a level to AcSmEvent
AcSmEvent.CALLOUT_BLOCK_ADDED Property

Event signifying that a callout block was added.

Syntax

CALLOUT_BLOCK_ADDED() As Long


AcSmEvent.CALLOUT_BLOCK_DELETED

Up a level to AcSmEvent
AcSmEvent.CALLOUT_BLOCK_DELETED Property

Event signifying that a callout block was deleted.

Syntax

CALLOUT_BLOCK_DELETED() As Long


PropertyFlags.CUSTOM_SHEET_PROP

Up a level to PropertyFlags
PropertyFlags.CUSTOM_SHEET_PROP Property

The value specifies that a custom property is automatically inherited from the sheet set to its sheets.

Syntax

CUSTOM_SHEET_PROP() As Long


PropertyFlags.EMPTY

Up a level to PropertyFlags
PropertyFlags.EMPTY Property

The value is zero.

Syntax

EMPTY() As Long


AcSmEvent.MODEL_RESOURCE_ADDED

Up a level to AcSmEvent
AcSmEvent.MODEL_RESOURCE_ADDED Property

Event signifying that a model resource was added.

Syntax

MODEL_RESOURCE_ADDED() As Long


AcSmEvent.MODEL_RESOURCE_DELETED

Up a level to AcSmEvent
AcSmEvent.MODEL_RESOURCE_DELETED Property

Event signifying that a model resource was deleted.

Syntax

MODEL_RESOURCE_DELETED() As Long


AcSmEvent.SHEET_ADDED

Up a level to AcSmEvent
AcSmEvent.SHEET_ADDED Property

Event signifying that a sheet was added.

Syntax

SHEET_ADDED() As Long


AcSmEvent.SHEET_DELETED

Up a level to AcSmEvent
AcSmEvent.SHEET_DELETED Property

Event signifying that a sheet was deleted.

Syntax

SHEET_DELETED() As Long


AcSmEvent.SHEET_SELECTION_SET_CREATED

Up a level to AcSmEvent
AcSmEvent.SHEET_SELECTION_SET_CREATED Property

Event signifying that a sheet selection set was created.

Syntax

SHEET_SELECTION_SET_CREATED() As Long


AcSmEvent.SHEET_SELECTION_SET_DELETED

Up a level to AcSmEvent
AcSmEvent.SHEET_SELECTION_SET_DELETED Property

Event signifying that a sheet selection set was deleted.

Syntax

SHEET_SELECTION_SET_DELETED() As Long


AcSmEvent.SHEET_SUBSET_CREATED

Up a level to AcSmEvent
AcSmEvent.SHEET_SUBSET_CREATED Property

Event signifying that a sheet subset was created.

Syntax

SHEET_SUBSET_CREATED() As Long


AcSmEvent.SHEET_SUBSET_DELETED

Up a level to AcSmEvent
AcSmEvent.SHEET_SUBSET_DELETED Property

Event signifying that a sheet subset was deleted.

Syntax

SHEET_SUBSET_DELETED() As Long


AcSmEvent.SHEET_VIEW_CATEGORY_CREATED

Up a level to AcSmEvent
AcSmEvent.SHEET_VIEW_CATEGORY_CREATED Property

Event signifying that a sheet view category was created.

Syntax

SHEET_VIEW_CATEGORY_CREATED() As Long


AcSmEvent.SHEET_VIEW_CATEGORY_DELETED

Up a level to AcSmEvent
AcSmEvent.SHEET_VIEW_CATEGORY_DELETED Property

Event signifying that a sheet view category was deleted.

Syntax

SHEET_VIEW_CATEGORY_DELETED() As Long


AcSmEvent.SHEET_VIEW_CREATED

Up a level to AcSmEvent
AcSmEvent.SHEET_VIEW_CREATED Property

Event signifying that a sheet view was created.

Syntax

SHEET_VIEW_CREATED() As Long


AcSmEvent.SHEET_VIEW_DELETED

Up a level to AcSmEvent
AcSmEvent.SHEET_VIEW_DELETED Property

Event signifying that a sheet view was deleted.

Syntax

SHEET_VIEW_DELETED() As Long


AcSmEvent.SHEETS_RENUMBERED

Up a level to AcSmEvent
AcSmEvent.SHEETS_RENUMBERED Property

This API was designed for internal use and has not been thoroughly tested.

Syntax

SHEETS_RENUMBERED() As Long